Beta Discussion

This new beta is great! I just loaded it up and love the new framing wizard pictures!! Really nice!

I haven’t even tried the rest yet but wanted to comment on this! beta appears to break several things in equipment profiles. I installed the beta on two computers and both exhibited the same behavior with my profiles.

Here’s a list of things that were broken:
Camera scale
Camera Readout noise
Everything on the Telescope tab
Everything on the Plate Solve tab
Autoguider Interface (no auto guider chosen)

If it’s helpful, here is a log file.

Joelshort…I concur

@joelshort Would you mind sending one of the broken sgp files so we can take a look?

Here is mine:


My laptop is Windows 10 Home.

It’s possible that yours works in development build but not in release build.


I have updated to the new beta today and my profiles have loaded without error . . . just to confuse matters.

It’s a new W10 pc if that makes a difference.

Here you go.
I note that the exact same profile loads fine on another computer still running It’s only in that things get broken.

1 Like

I found the exact same problem. A Sequence with the profile loads up fine but if you go to tools>Equipment Profile Manager and pick a profile you get the error

I’m running Window 10 Pro. I have another computer running Windows 10 pro running SGPro and it loads the profile without any issue.


Just as an update - I stand corrected. I’m imaging now and opening my saved sequence populated the equipment and settings data correctly.

However, when I clicked on the Equipment Profile Manager I had the same error message and missing data/settings as others above.

I saved Sequence as Profile and settings were transferred to the Profile as they should. As I am imaging I haven’t closed SGP and re-opened to see if the Profile saved properly.


OK, thx. This has been fixed. New beta release incoming.

I’ve had a problem with AF using the beta this evening causing me to abort the whole sequence and I am waiting for my ccd to warm up and I’m going to re-boot the pc and re-start the sequence.

All was proceeding as planned, AF all OK, and then I did an auto-meridian flip. Afterwards I went into a loop with AF constantly happening: it focused with Lum, finished AF, changed to my Ha filter, adjusted focus position and then immediately switched back to Lum and began the AF routine again. This happened over and over. Aborting did not break the cycle, neither did resting the sequence nor disabling smart focus.

I am about to re-boot my pc and will post a log as soon as I can.




This beta is working fine for me in terms of the equipment profile. The mosaic wizard images are a huge improvement. Thanks for making this update.


@BarryWilson I think I know what this is… I’m guessing this was after a meridian flip or at least on that side of the mount.

Yes, after a meridian flip.

I re-booted SGP but AF loop persisted. I then re-booted pc and downgraded to the .17 beta to make the most of the night (1.43am UK time) and to get some more Ha subs on The Wizrd Nebula.

Will post a log nevertheless in the morning when I get a chance.

Sounds like you have an idea of the issue.



Just made a release of that hopefully corrects this issue (and the profile issue as well).


Thanks Ken, quick work as usual.

I’ll test the new centering routine with my Paramount MX+ tonight!


OK… have fun, but also have have no expectations that it works… we have not tested this AT ALL… not even a little bit.

Loading old Equipment Profile now works.


That’s OK. I’ll still check it out. It’s easy to go back down a version.