- SequenceGenerator has stopped working


I’ve just given up Windows 10 and reverted to a clean install of Windows 7 Pro on my observatory laptop.

I’ve downloaded and installed SGPro but it stops working just as the splash screen gets to “Checking for updated versions”.

I’ve uninstalled and tried, and - and they all work fine.

I’ve now unistalled these and downloaded again - reinstalled …and it stops working at the same point in the splash screen.

No rush here - because I’ll run with but I thought you should know.



An update …and another problem.

When I tried to register SGPro on the new machine, I got am “Index was outside the bounds of the array” message box and SGPro now opens in Lite version. I’ve tried this several times now and changed my password - still happening.

Thanks for any help you can give.



…and a further update, all of the SGPro 3 versions have stopped working now, so I’ve reverted to now…and this has registered fine. So I’m running but not on V3!

Off to bed now!



I would guess it’s something with your default profile.

Go here:

Backup and then remove everything under that directory. Then start up SGP. If that fixes it please find your default sequence that was in that directory and attach it here so that I can fix what ever is causing the issue.


Hi Jared

Thanks for your reply and sorry for not responding sooner.

I’ve uninstalled SGPro and reinstalled - the same problem occurs.

I’ve done as you’ve suggested and SGPro get as far as “Checking for updated versions…” and stops working.

Expanding the error message gives me this:

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: sequence generator.exe
Problem Signature 02:
Problem Signature 03: 5b64f26c
Problem Signature 04: Sequence Generator
Problem Signature 05:
Problem Signature 06: 5b64f26c
Problem Signature 07: 27a9
Problem Signature 08: 3b5
Problem Signature 09: System.IO.FileNotFoundException
OS Version: 6.1.7601.
Locale ID: 2057
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

I’ve just noticed that, although SGPro doesn’t want to run, it does create a log file. The latest is attached.

sg_logfile_20180809112007.txt (19.2 KB)

Any light you can throw on this would be gratefully received.



Interesting. That log seems to suggest that one of the system libraries cannot be found. Can you verify that the .NET Runtime (4.0 or greater) is installed, and if not can you install it?



Fantastic Jared - that’s nailed it!

I’d changed the HDD (to really, really get rid of W10!) , installed W7 and done all the updates to SP1 etc…but there was no .NET framework on it.

Would this be a useful check to be carried out at install time??

Thanks very much for your excellent help (as always!)

Kind regards


The installer should be checking for .NET during install :man_shrugging:


Thanks again Jared