AF Sample size not being saved

After saving sequence as defult profile and/or saving the sequence on subsequent starts of SGP I have to reset the AF sample size each time.

Other autofocus settings are being saved.


I tried many different permutations, but could not get step size to fail in saving. I set it in a profile, made it the default, saved the sequence over that profile, saved the sequence. Every time it saved properly. Please see this post and we’ll see if we can figure out what’s going on:

Not “step size”.

“AF sample size”.

It’s the slider (range 15 to 100) directly above the “run” button in the auto focus panel. It’s also in the AF settings dialog, but from memory that one has a different name.

Ah yes sorry. We may consider adding this data to the sequence at a later date.

OK thanks

Also you might want to consider making the name consistent for the AF settings and the AF Panel.

One is “AF Sample Size” and the other is “Star Detection - Sample Size”

Yes, in many ways this is like the “slave to telescope” issue. Both are things that are not saved and can trip you up if you forget to set them as required for your system.

I set a beginning of sequence custom reminder for stuff like this but it seems to me that one should be able to save these sorts of things as part of a sequence/profile.

Yes, this seems reasonable (this can be done prior to the 2.4 release as it is non-invasive).

A couple things on this thread:

To be clear, the sequence does actually save this value, it just does not exist as part of a profile. When I say we may add this in the future, I am not referring to adding it to profiles (I don’t necessarily think this value is set based on combinations of equipment, but rather, is a property of the target). We need to figure out how to do this without making it super confusing.

After reviewing this, I think we will probably leave the labels this way. The former says AF sample size because the control is outside the context of auto focus settings. The latter simply says “sample size” because you are clearly in the auto focus settings dialog. Regardless, the tooltip and help manual all say the same thing.