ANSVR local astrometry question

I recently transitioned to a new camera and have been tweaking plate solving as a result. I was having some trouble getting (local) to solve at first but I think I have it (had to tweak the exposure settings). I usually like to watch the ANSVR log while it plate solves (I like to see the something is going on) and noticed that nothing was happening in the log despite getting positive plate solves back. My first thought was that it was defaulting to (remote) so I checked my settings in control panel and in the equipment profile used for the sequence, all set to (local). What gives?! So I cut the internet connection to be sure that it was going to the remote server… it solved. So what I’ve got is that it’s actually using the local files, but the ANSVR log isn’t showing anything. I’ve attached a screen shot which shows a successful solve, the open log file (showing no activity) and no internet connection.

Any clues???


One thing they recently added at the bottom you can see it says its (Waiting on ANSVR) so you know it is going to the local computer. It used to be confusing when it said the same message for both local / remote however that definitely shows it’s going to the local.

Check the actual log file manually here:


Have you tried to reboot and does it continue to do this?

One tip I read on this forum was to set downsampling to 4 which speeds up plate solving.

Wow that’s a doozy! Maybe check NETSTAT and see if you have multiple instances. Compare the port used in SGP and ANSVR settings.

The date shows 2018 as well on that watch ansvr log window too, strange.

entilza figured it out.

The “watch ansvr log” shortcut opens the ansvr log with the latest timestamp in the filename. In your case it is picking up the 2018 file every time. You can fix the problem by renaming or deleting the 2018 file.


1 Like

Wow! You guys are the best!

I didn’t even catch that. Indeed, deleting that file did the trick (took me a while to find it). I’ve had some issues with the PC stick that I’m running this on with regard to the clock. I leave it unpowered when not in use and the clock is often off (one time it was set to 2058!) and windows experiences all kinds of problems. I’ve now got it set to use internet time, but that obviously won’t work when not connected.


Cool! Im using an intel compute stick and the time seems fine not sure which yours is.

Be sure to try the downsampling too and report back… Infact I think it was Andy who suggested that setting as well.

UPDATE: Got solving working every time with my DSLR. Since installing my new CCD, local has become somewhat unreliable - solves in most regions of the sky, not all. Particularly, blind solves (solve and sync) at the beginning of my imaging runs where I am near polaris do not seem to work. Are there any recommendations with regard to exposure or binning to improve things? Last night neither local nor remote was working on start. Eventually I moved the scope to a location near Arcturus and that worked right away. Tonight I’m going to stay near polaris and change exposure settings (binning at 1 x 1) to see if I can get that to work. Suggestions would be appreciated.


P.S. once I’m synced, PlateSolve2 is working every time now.

From a recent thread you should be slewing to the target first then plate solving there rather than plate solving polaris. Havingh both the target checkboxes “Center to” and “slew to” does a slew first then the centering process.

1 Like