ANSVR refuses to solve this image

I have an intermittent issue with ANSVR and need help: Every now and then, it will refuse to solve a given image. I have put one example (the original image), the SGP-Log and the ANSVR-Log here:

I am using SGP

To reproduce, start SGP and use File → Open Image to select the “2016-07-10”
Right-Click on the Image and select “Plate Solve” and then “Blind Solve”

The blind solve always times out on this sky region. The primary solver (Pinpoint) solves this in seconds but I normally need the blind solve for the first solve after a slew.


I recently solved a similar problem by first uploading my image to website. Then if you read the log it tells you which index it used to solve.

In my case it was using an index from their wide field catalogue that was not available from the ansvr index downloader. After I retrieved the wide field index all my solves are great and much faster.

I did what I mentioned in the prior post, and solved it with index file 4109.fits

This file is not located in their regular downloads or through the ansvr index downloader.

If you go to the main download page there is a link to for “Wide field” images.

Currently: Index of /~dstn/4100

If you download the 4109.fits and put it in your index directory: %appdata%\Local\cygwin_ansvr\usr\share\astrometry\data

(move the current *.FIT index files out of there for a test) and see if it works out.

1 Like


Your image solved for me with index 4207-07. Here are my ansvr settings:

I agree with @entilza that it is a good idea to check your index files to confirm you have the the 4207 series. Have you confirmed that your image scale is correct in SGP (2.12 arcsec/pixel)? You could also try the ansvr settings downsample = 2 and objects = 100 to see if that helps.


1 Like

Thank you both for the great ideas.

First I tried Andy’s settings. The image solved in 165sec after I set the number of objects to 100. It seems that the computer was overwhelmed by the number of stars. I already had the index files from 4207 to 4218.

Then I downloaded the 4109 wide field index (and, while I was there, also the 4108 and 4110, you never know …) This time, the solve took 12sec, which is absolutely fantastic.

With these settings, I could use ansvr as the primary solver.


1 Like