Ansvr-setup-0.15.2 and Windows XP - do they play nice together?

After struggling with Elbrus for two hours in 20 degree temps the other night, I finally gave up and packed it in for the night. But a search online turned up links to ansvr and today I installed it on the old desktop computer with high hopes that I had found the solution to my plate-solving woes.

The exe seemd to install with no problems, but when I tried to lauch the program to download the libraries, I got an error message that says the program isn’t a valid Win32 application.

I did install ansvr 0.12 and it seems to work with no problems, but I was just curious to know if the newer version is compatible with Windows XP, and if so, what I missed in the installation. Thanks!


Could you please give this a try:

It is a version that should run on XP. I do not have an XP machine to test on, so it would be great if you could give it a try.


1 Like

I’ll give that a try today.

I am impressed already with the tests I did with version 0.12 – it only failed to solve one image I tested, and since it was a narrow field, I’m pretty sure it was because I hadn’t downloaded the files needed to solve it. I can’t wait for the skies to clear so I can test out in the field!

Andy, the new IndexManager file worked great. Thanks for sending that.

I also found out why none of the other .bat files worked. It appears that the file was looking for a variable that didn’t exist on my machine. I just hard-coded in the path to bash.exe in each batch file and everything is working great now. This is going to be a HUGE help since we don’t have internet access in the observatory. Thanks for all your work on making this available.

Great, thanks for posting. I will update the installer to include this version of the index downloader so future XP users will be covered.

Could you please prove more details on this problem? To which .bat files are you referring? There should not be any requirement for environment variables or editing batch files. I’d like to know more about the problem so I can fix it.


I don’t have the XP machine powered up right now, so I’m working from memory here…if I say something that doesn’t make sense, let me know!

When I ran ansvr-setup-0.15.2, it put some .bat files in the “c:\program files\ local server” folder (I think that was the name of the folder anyway) and it put shortcuts to those .bat files on my start menu. Runnning these shortcuts were supposed to start the local server, terminate the local server, start the log viewer, etc. However, when I clicked on them, I got a command prompt but with an error message. When I looked at the .bat files, they were all attempting to run a file named bash.exe with different switches. The problem was that the path in the .bat files that pointed to bash.exe wasn’t a valid path on my machine. The .bat files were using a system variable, something like %localappdir% and I either don’t have that variable on XP, or it pointed to a different place than where cygwin was installed. I just did a search for the bash.exe file, and when I found it modifed the .bat files to point to that location. Everything worked like a champ after that!

Again, just want to emphasize how much I appreciate your work on this program. We were having fits with Elbrus, mainly because it is so particular about the coordinates, the pixel scale, and the angle. When the encoders on the mount aren’t synchronized with their actual position, Elbrus simply will not work…period. And without an internet connection in the observatory, I couldn’t use the website for solving. Your solution is exactly the thing I’ve been looking for!

ah, I see now thanks. An XP incompatibility in the .bat files.
Would you mind trying this batch file on your xp machine when you get a chance?
If you run it from a cmd prompt and it works it will echo “hello”; if it does not work it will display some kind of error. If you could let me know if it works, I can update the batch files to work on XP.
Thanks again,

We’ll test it out tomorrow and report back. Thanks for checking on this. I don’t know how many people use XP anymore, but this old desktop seems to work much better for us than the laptop with Windows 7 64-bit did! LOL

Hey Andy, sorry for taking so long to get back with you.

The batch file didn’t work as written…it gave this error message:

‘""C:\Documents’ is not recognized as an internal or external command, operable program or batch file.

However, it seemed to work with one minor adjustment…I took out the quotes around the line calling bash.exe, thus:

@echo off

if defined localappdata (set d=%localappdata%) else (set d="%USERPROFILE%\Local Settings\Application Data")

%d%\cygwin_ansvr\bin\bash.exe -l -c “echo hello”

I hope this is helpful.

Very helpful :smile:

That gives me enough to info update the installer for XP. Thanks!


There is now an updated installer on the ansvr site, ansvr-setup-0.15.3.exe. The only difference relative to 0.15.2 is that the Index downloader and the batch files now also work on XP.

There is no need for anyone who is already running ansvr to install the update; the change is only relevant for those who were unable to install ansvr-0.15.2 on Windows XP.