ANSVR Sometimes Stuck on Validation Frame

I’m using the SGP latest version with Ansvr 0.18 (the offline solver). Sometimes (not every time), SGP will do steps 1 to 3 flawlessly but will then capture the validation frame for step 4 and just sit there, saying “Image preview opening…”. After some minutes pass, it simply aborts, parks my mount and closes my roof.

If I close SGP and reopen it, then it tends to work. Keep in mind my CCD camera is working perfectly as once plate solving works, it captures exposure after exposure without a hitch. I think I need to ensure that there’s no image open in SGP (such as the sequence’s stored image or a recently captured exposure) to guarantee plate solving works. It’s as if having an image open in SGP stops it from somehow downloading the plate solving frame.

Is this a reported bug or am I alone? :stuck_out_tongue: Thank you!

EDIT: My PC’s specifications can’t be the issue as it has an Intel Core i5-4500U CPU, 16GB DDR3 RAM and a 250GB SSD. I’m running Windows 10 Pro.

I’m playing with it now and it seems to happen pretty much every other time. When a plate solve frame is downloaded in step 2, the command prompt window opens as if Ansvr is processing the data, and it is. Once solved, it proceeds to step 3 to re-centre. Once re-centred, it proceeds to step 4 to capture the validation frame. Unfortunately once done, it sits there and the command prompt window does not open this time, so it just sits there. I’m looking at Ansvr’s status and all it says is “Waiting for data”, so it seems SGP hasn’t told Ansvr a new frame is there for plate solving.

EDIT: Sometimes it happens in step 2 as well, but it’s more rare. Basically this seems to be an issue of SGP calling Ansvr with the plate solve frame and Ansvr actually responding.

Are you using a firewall? If so, try it with the firewall turned off.


I can try turning off the Windows Firewall, sure, but I’m surprised because this issue came “all of a sudden”. I think it’s with version though. I will revert back to and try that because I have never had this issue before.

Andy read this thread (on my e-mail request) and he believes this is an issue with SGP completing the plate solving exposure download. Now, I do know SGP is working with my camera perfectly in that all actual imaging exposures are downloaded perfectly well, but I also think Ansvr is working well as when “nothing happens”, it’s actually sitting there “Waiting for data” so supposedly Ansvr is doing its job, just that SGP is not handing over the task of plate solving.

I will try this all again with SGP and will report back. If the problem persists, I will post a log file.

Actually, what I was trying to say to you was that you should post your SGP log file as described in How To Ask For Help

Without seeing the log file everything is speculation. We can make up theories like camera download problems but the information of what really happened is in the log file. If you post the log file Jared or Ken can look at it and very likely see what actually happened.


1 Like

I’m happy to post it but the observatory is having some power issues and I don’t have access to my remote computer at the moment. Regardless, I will try SGP with Ansvr 0.18 and report back (with a log file if it doesn’t work 100% of the time).

Please try (not with ANSVR.


Last night I tried SGP and it was working flawlessly with Ansvr 0.18. I did a complete reinstallation of both and a reboot afterwards. No problems last night. I will probably try SGP during this week. I’m just sorting out something with my telescope focuser, unrelated to SGP.