Anyone else issues with GNS?

I tried to install GNS and run a test and ran into nothing but trouble. First, the app instantly crashes on my (just pre-air) iPad. Same (last weeks update of iOS) iOS version on my iPod and it runs GNS just fine - go figure. Android is also OK. FYI, this is the free version, I am glad I did not just buy the somewhat spendy paid app if it is no better.

The Windows GNS server is a mess with one error when doing the recommended comm test from the command line and a much messier looking error when running a test sequence in SGP beta 10.

I am pretty sure this is not an SGP error so do not expect SGP to do anything. I have emailed GNS about this but do wonder about their support since the link to their support group does not even work.

Errors shown below.

I really just wondered if others have seen similar issues.

In any case this really does argue for a simpler, browser based monitor dedicated to SGP that was discussed on another thread in the past few days!

Make sure you’re not running GNS – let SGP start it for you as it is included in the app folder. What is happening, I think, (it has been awhile) is that SGP is trying to launch its copy of GNS when you may already have one running, and it’s telling you the port is already in use.

OK, that makes sense, I should have thought of that from the nature of the second set of errors which looks like two attempts to use the sockets. I did not know SGP did the start. I will try it.


Bill - I’m using GNS without issues (apart from occasional comms glitches). I had GNS installed with my AAG Cloudwatcher and had to remove the safe and unsafe scripts that loaded and communicated to GNS. Once I did that, SGP starts up an instance of GNS and I use SGP via the ASCOM safety monitor to check on the weather.

Jamie (GNS author) does need to make some display changes to the web and app, so that you can read the messages properly. He knows about these and it is on his to-do list.

Thanks! I just got it running and it was because it was trying to start a second instance. I will leave the thread and screen captures posted in case someone else sees this (user error) issue.

I will let GNS know - there is still the iPad crash they should know about.

OTOH, I would still love to see a browser based monitor!

This is true and we have tried to highlight in the help files (we can probably be more user friendly about this and check if it’s open, display a warning and let you fix it). It is not ideal right now (and we may have a better solution in the future)… but SGPro must open the GNS server because it needs access to the process “handle” (which it cannot get if opened manually). GNS will fail badly if it is already open when you try to start the sequence. Unfortunately, this means that if SGPro opens the GNS server and then you close SGPro, you also must close the GNS server manually prior to starting SGPro again (we can also try to automate this).

I have run a couple tests with both Android and iOS and both work fine now (except on the iPad where the app crashes as soon as it starts).

Just have to decide on iOS or Android. Was gonna do iOS but just got a notice of Lollipop availability on my older Nexus 4 so may do Android.

Moving to feature requests so we can prioritize code that helps users if they happen to have started it manually. Shut it down and restart it? Warning? Not sure…

Stabilized the GNS startup process in SGPro can now detect if the user has started GNS outside of SGPro, shut that instance down and start a new one that SGPro can communicate with.

1 Like