Anyone else running SGP under Parallels?

Hello everyone!

I just love SGP, really good package which has given me great results, vastly better than other packages I’ve tried. I’m a committed Mac user, and I have been using a very old - and now dying - Windows computer for my imaging. Now I know better than to ask the devs to do a Mac version of SGP, I know that’s been firmly declined in the past…

I would love to use a Mac to control my imaging, I have Parallels installed on my MacBookPro, ASCOM and all relevant drivers too, and they are showing up in SGP as they should. Problem is…my devices (cameras, focuser, etc) are not recognised by the Virtual Machine, I get messages saying Connection Error or Driver Not Installed etc. I understand there should be a quick fix here, and I’ve run through a few things recommended by Parallels which refer to connecting a printer or USB drive - something simple. But ASCOM is clearly a far more complex framework, I can find virtually nothing at all out there.

I know it can be done, there are a couple of high-profile YouTubers out there who do, but I’ve asked them, and they say they can’t remember how they got it to work, it was years ago. Something about an Intel Board Driver?? OK.

Any up-to-date help would be much appreciated. I can’t tell you how much I hate Windows, and the thought of buying another Windows laptop for this one, solitary purpose, fills me with sadness.

I agree completely; but I did make the ugly decision to buy a relatively cheap laptop with Windows 10. It’s not that expensive, and, frankly, a lot less difficult to work with. I have found Parallels on MAC to be itself problematic over the years (abandoned it a couple years ago)

Yes, same. I got a very old Windows laptop for free, it has been magniifcent in so much as it got me imaging reliably, but dealing with the trench warfare that is Windows after all these years in the blissful and carefree existence of MacOS, has been a trial. And that’s acknowledging that Win10 is vastly better than Win7 etc etc…

Yes, you may be right, this is probably an exercise in stubbornness and ego to try to wedge SGP into Parallels, when this old laptop dies I may have to just buy another small Windows laptop. Soooo galling that I have to buy and maintain a whole computer for one - literally ONE - purpose…

You can make it work…it’s not ideal and we don’t support that configuration. Your best option is to use bootcamp rather than parallels. And if you want you can still use the bootcamp partition from within OSX by using parallels. Essentially EVERYTHING needs to be on the windows partition. If you try and bridge the two you’ll run into some weirdness. Also make sure you keep sequences and files for SGP on the windows partition as well. This is why I’d recommend initially setting it up through Bootcamp.

I did have Parallels corrupt one of my Bootcamp installations but YMMV.


Yes, after playing with SGP under Parallels for the last week or so, I’m starting to gather it’s a needlessly difficult exercise - certainly well beyond my dreadful IT skillz which led me across to Apple in the first place. When my current Windows machine ends its natural life, I’ll just get another one.

Yes indeed I have run SGP on my various MacBook Pros under Parallels for years, without any problems related to the OS or virtualization.

The only “trick” is choosing which OS gets assigned to which USB device as you plug them in. If you only use certain devices through Parallels on the Windows side, you can check the box for “always use this choice.”

1 Like

I also run SharpCap Pro and iOptron iPolar and TheSkyX Pro with ASCOM drivers under Parallels without any trouble at all.

I’m surprised to see so many people people report difficulties with this. I find it to be completely painless. No point having two laptops when I already own a really nice one that runs all my astro software as well as my daily work!

1 Like

Hello Air!

Yes I keep selecting the Windows option, and ticking the box to always do that, but no success. All devices just invisible, every single time.

I think the best way to handle this is to have an Intel NUC at the telescope and the access it from your Mac OS using Teamviewer. At home I connect through my wifi network. When I go out to star parties I use a HooToo network to connect the two machines.

Yes, realistically I think that’s the plan. I actually have a friend’s NUC here to try out, it runs off 12V too so can use the same battery as my rig. Problem is just how power-hungry these laptops (or NUCs) are, consumes twice as much as the rest of my rig combined. Would love to move to a RPi based solution (5V, 1A average) but my experience with KStars/EKOS is that it’s a buggy unstable mess which is forever in Beta, and ASIAir is just way too rudimentary. I have hopes for them both as RPi4 brings more capability, but for now it’s SGP, a Windows PC, and a yuuuuuuge battery.

I run my NUC from a 12 volt battery at star parties. I have a " UpBright NEW Car DC Adapter For Intel NUC Kit" adapter from Amason that boosts the voltage up to 19 volts. I’ve never had a problem with my deep cycle marine battery running everything and my solar panel fills it right back up the next day.

Sounds like a good plan.

Bizarre. In a decade of running Parallels on many macs with Windows XP, Vista, 7, and 10, Home and Pro and LTSB, I’ve never had that happen.

That said, I also use the NUC or velcro Intel Compute Stick with TeamViewer arrangement when I’m home. But when I’m out and about I prefer to run everything off my MacBook. It’s just simpler.

Nothing wrong with having a bunch of options. But I would certainly not give up on parallels. It works like a charm.

I wonder if it’s some kind of setting in Parallels?

For my NUC Intel 7i3BNK, Intel specs say that it can be powered with voltages from 12 to 19VDC.

I run mine directly from my PS runing at 13V, with no adapters to increase the voltaje to 19V.

I supposed it is OK, so far I haven´t had any problems.



I ran SGP under Parallels without problem. Some tips:

In the Virtual Machine option make sure that the Enable Retina Display is not checked. Also ensure that all of the CPUs are available to Windows with plenty of memory assigned.

When setting up for the first time make sure that your Mac can actually see all of the devices:

Once Windows is running, check that the External Devices are all selected from the Parallels-Windows options.

1 Like

I have been running SGP under parallels for years with no problem. Like other people have mentioned here, you have to assign the USB devices to Windows. You can only do this once the devices are connected and powered on.

This is also mentioned in the manual for Parallels.’s%20Guide/32916.htm’s%20Guide/32916.htm