Anyone experiencing issues with ASI1600 cam and calibration frames?

I have started to have a problem using SGP to take calibration frames that are usable. I am not saying it is SGP’s fault. I am just saying this is what I am using. I have been up and down the ladder experimenting with this. I know I did not have any issues back a couple months ago. I have since upgraded SGP a few times with new versions released. I am currently using .21 - and I upgraded the ASI1600mm-c driver that was available.

Basically use of either dark, bias or both reduces contrast and brightens with the image overall. As though going from a nice image to an image shot through severe LP, when applying the calibration frames.

It’s not my first rodeo for using and applying calibration frames which makes it even more baffling.

This is an example of the problem. Left no calibration frames applied. Right, darks and bias applied. Dropbox - Error

Any thoughts?

Did you re-take bias, dark and flat AFTER ASI1600mm-c driver upgrade? If you re-used bias, dark and flat before ASI1600mm-c driver upgrade and tried to calibrate with new lights after ASI1600mm-c driver upgrade, then it may not work this way.

Bottom line, anytime ASI upgrades their camera driver, it’s always a good idea and possibly necessary to re-take bias, darks and flats.


It looks to me like at least the bias are not calibrating properly. There are clear vertical lines in the bias/dark calibrated image, and the amp glow is not being corrected either. It could certainly be caused by a mismatch of drivers as Peter suggests. Or it could be that your bias and darks are not being applied properly. With these CMOS cameras you do not want to optimize (i.e. dark scaling) the darks.

You didn’t mention that you were applying flats. Have you tried a full calibration involving flats too? To me it just looks like after applying darks and bias it changes the image just enough that the STF stretch really emphasizes the dark regions and overcompensates on the lighter regions. Flats might take care of this.

Hi Peter - yes I retook the calibration frames after SGP update and ASI update. Both updates were done at the same time. Retaking the calibration frames was part of the up and down the ladder, experimenting I mentioned. I even had a friend (more experience/knowledge than I) look at things and he experienced the same issue with the lights and calibration frames as I did in that it was affecting the overall contrast and brightness. We did not arrive at any conclusions as to why, yet.


Hi Joel - I did not take or apply flats. That is correct. I often don’t when experimenting with imaging. In this case I was experimenting further with the high gain/offset for narrowband with the ASI. I just use PI ABE or DBE. Not taking flats, and just using the dark/bias back a month or two ago, worked fine. Its just recently this problem popped up.

Is it possible to revert a couple versions of SGP without loosing my current settings? I was thinking of taking darks again using a slightly older version of SGP, just to rule it out. Right now I’m stuck with some variables I can’t cross off the list.


I really don’t see how this could be an SGP issue, but just to rule it out I guess you could go back to the stable release .17 You’ll need to uninstall SGP first and then install .17 I don’t “think” your settings will be lost, but I would certainly backup your equipment profiles etc. first.

FWIW, I have the QHY163M and in my very limited experience it seems like calibrating these CMOS cameras is significantly more “touchy” than CCDs. I don’t know why that is…

OK thanks Joel. I am thinking its not SGP either but I need to rule some things out. I will try going back to .17 and do some testing. Will report back. Thank you for the help thus far. Everyone.

I wanted to report back on this. I reverted to 26.0.17 and reshot darks/bias, calibrated and integrated the data again. No problem like I was experiencing with 26.0.21 - however… I wanted to retest things using 26.0.21 and so I installed it again. I then again shot new darks/bias and used it to calibrate the same data and integrated it. The result was good. No problem like I had experience previous using 26.0.21. So I’m not entirely sure what was causing the problem. I only reverted to the stable version and installed again the latest beta. No other changes were made. The good news I’ve confirmed it wasn’t SGP. Also appears it was not the new ASI driver. Unfortunately I may not know the root cause but I’m glad things are working correctly again none-the-less!