ASA DDM 85 Driver

The ASA Astrooptik Telescope Server does not work properly. The scope connects but give fatal errors once SGP is started

Connecting to the mount using the ASCOM Driver for TheSKY X does better but causes meridian flip problems. Pierside is checked in TheSKY X ASCOM Driver. Time to flip gives nonsense values such as 66 hours and 2:30 PM.

startsg_logfile_20181113202636.txt (61.9 KB)
sg_logfile_20181113201013.txt (172.4 KB)
sg_logfile_20181113204906.txt (161.8 KB)
sg_logfile_20181113202807.txt (202.0 KB)

Any seen this before?



We’ve seen a couple of cases of this recently. Seems like a rounding issue. I’ve added a fix for it and it will be out in the next release of SGP.


Can you send me an advanced copy for testing?


Will it be release very soon?

I tried the last Version of 2.X. Same problem.
At one time the ASA driver worked fine.
I have not used SGP for a bit over a year.
The ASA driver has been updated since then.

I am guessing if I roll this back if might work. I would rather wait for a fix if that like to come soon.


Important follow rolling back to an earlier version of ASA’s Astroopik Server ( telescope driver) works fine.
I did a whole run including flip last night without error.


1 Like