Ascom driver not reporting side of pier, time to meridian correct but not usable

so I have an ascom driver that does not have side op pier.
As suggested I can use the POTH hub to simulate one, unfortunately that renders my system slow and unreliable …

What I want to see is that SGP keeps the time to meridian it displays correctly when I disable the Auto meridian flip option, because SGP seems to retrieve enough info from Ascom driver to show correct time to meridian when no Auto flip action is required. (very frustrating to see the correct time, only to see it disappear when you want to use it)

(other softwares like ACP are apparently able to do so because people using the same mount + software can do meridian flips)


Have you contacted Gemini about this? If there’s a problem with the driver they will probably be interested in feedback so they can fix it.


Yes, the driver in question is not being further maintained it seems.
There is another driver that does report side of pier but that one reports completely wrong time to meridian and more over is not reporting end of slew reliable so that one is so immature that it is not usable …
I know one other user that uses The Sky X with Maxim and autopilot and he can do automatic flips …

And what really is frustrating is, is that SGP reports correct time to meridian, it just disappears when you enable AUTO flip feature …


We must be looking at different things, I found ASCOM.Pulsar2.Telescope.dll version dated the 26th January 2015. If that’s the one that you think has problems it may be best to work with them to get it working properly.

That is the new driver, it is buggy, and it seems the developer is not supporting it and or willing to fix things for Gemini … I asked that question …
So for now we are stuck with the older one it works, but is missing pier side … so automation in SGP is not possible. (as already mentioned automation with autopilot + The sky X and maxim seems to be working)


The “Time to Meridian” and “Time to Pier Flip” are calculated differently and are not the same thing. The “Time To Meridian” only needs to know the Hour Angle of object and the current sidereal time. Where as “Time to Pier Flip” must also take into account any pre/post meridian flip behavior as setup in the Pier Flip settings as well as the current pointing state of your mount. For instance if your mount is reporting that your scope is on the West side of the pier then the “Time to Pier Flip” will be “N/A” because no flip will occur. We only display a “Time to Pier Flip” if a pier flip will actually occur.

Unfortunately it sounds like your ASCOM driver is reporting the incorrect side of pier so to SGP it appears that the flip has already occurred.

Like they say, “Garbage in, Garbage out”.

May be worth checking the sidereal and location time in this driver as SGP uses both of those to calculate the time to meridian. It could just be a config error in the driver.


Thanks Jared,
the driver that has side of pier, has only one configuration option, the comm port …
Now I understand the difference in time, SGP takes it from the mount not the Computer …

But even then the driver is useless as it has unreliable end of slew reporting, SGP keeps waiting and waiting in 1/2 flips.
I tried to solve the Time to meridian issue by adjusting the degrees past meridian but that SGP limits to 20 and I needed more like 25 to 30 …

So I have 2 options, hope for a fix in the ascom driver or look at CCD Autopilot and The Sky X, as that seems to work …



Can you try the ASCOM Conformance Checker with this mount and BOTH drivers please.

The checker is available here
Conformance tests all the functionality of the driver and records what it gets in log files, please post them, with any notes about what you see happening.

This will give us accurate data that can be used to help us - and the manufacturer - see what can be done to fix this.


Tried to run the Conformance checker,
for both drivers I get the error;
Incompatible Driver
This 64 bit capable driver is registered as a 32 bit COM driver
Please contact the driver author and request updated installer.

If I select them directly …
They work through the Generic Hub, so that is what I will post.

The recent driver, Pulsar 2 did never run to completion after 2 slews or so it kept on slewing (I already new it does not reliable detect end of slew …). So I had to stop the test manually as my dec kept on running …
So Pulsar 2, does report side of pier, but wrong time to meridian and it keeps on slewing (wrong time is more like it takes UTC time from GPS without adjusting for location)

The older driver does run to complete end, but has no side of pier, I can somehow simulate this with the POTH hub, but as already mentioned it renders my system unresponsive … and not reliable …



There’s an option in Conform - menu - Options - Conformance Options - Run as 32 bit on a 64 bit OS. These are 32 bit only drivers. It will help if you can connect directly so there’s nothing in the way to confuse things.


From what I can see the original Pulsar driver, version implements Version 2 of the telescope interface. It throws a not Implemented exception for reads of SideOfPier, otherwise it seems pretty good.

AFAIK reading SideOfPier only became compulsory for version 3 of the Telescope driver.

Version 2 of the driver reports that it implements version 3 of the interface but has multiple issues to do with housekeeping and was halted before it got to the SideOfPier things.

I’m not sure what to suggest. While the first driver seems OK it doesn’t implement things that SGP regards as essential. The second version doesn’t seem to be finished. It’s possible that the mount manufacturers are essentially hardware people and are not aware of the problems.

Put me in contact if they need someone to sort out their driver :smile:


I raise the post.
I have problems of connection with Pulsar2 and the ASCOM driver. Pulsar2.telescope.dll version P.Cagas
However it works with the former ASCOM driver. Pulsar.Telescope.dll version 5.0.13 P Kitching.

I used Ascom diagnostics:
This is what I get with win 7

And what I get with win 8.
The driver does not load the values of RA, DEC, lat, long, time… This is what stops operating with TSX, sky map and maximDL software…
What configuration of driver do you have (driver pulsar, firmware…)
Is this a problem signing driver? I tried to disable the compulsory signature of the driver, but it has changed nothing.
I do the test with Pulsar Commander under win 10. The com port opens, the values of RA, DEC, lat, long and time are well displayed. The command with the hand controller works also.


The problem with the old driver not implementing side of pier could be resolved if SGP were to attempt to do a slew to the other side of pier at the hour angle that the user specifies - a few minutes after crossing the meridian.

I suggested this a few days ago Handling meridian flip


Oh this thread is a alive again! Cool.

The cages driver is worthless, it’s unreliable for me, it misses sometimes the end of slew … so mount keeps slewing …
The HA is hours off for me, I guess some issues with UTC (some other users don’t seem to have this)

I use the old kitching driver with POTH hub and simulated SOP, and important connect over ethernet as USB is really really slow …

I reboot every night my system and could do automated meridian flips … but I really want a good ascom driver for P2 or that SGP will let me choose to flip mount (as other softwares like ACP can meridian flip P2 mounts)