ASCOM Option in Camera Chooser - QSI Driver Issue

I am not able to connect my new QSI690WSG-8 in SGP using the QSI 2020.07.30 Driver package. I contacted the seller who contacted QSI. QSI responded that in order to correctly connect with the camera, you need to “select ‘ASCOM’ as your camera type”. Once ASCOM is selected you are supposed to select ‘QSI Camera’ in the ‘ASCOM Camera Chooser’ after which the QSI ASCOM Configuration window will appear.

SGP has no ASCOM in the Equipment Profile Manager for the Camera (or any piece of equipment). I can see the QSI Camera options - but I am unable to connect to the camera when I select the QSI Camera (get various error messages - all of which were sent to QSI for review).

Any suggestions on how to proceed?

Have you installed the latest Ascom system ? Download Center

Yes - ASCOM Platform 6.5 SP1 - 6.5.1.3234

SGP Version 4.0.0.680

.NET Version 3.5

Windows 10 Pro Version 21H1 OS Build 19043.1237

Processor Intel Core i3-6100TE RAM 16GB 64 bit operating system

Also, I can connect to the camera using Maxim DL V6. QSI has a MAXIM DL Plug-in that you install as part of the 2020.07.30 Driver package - however, even with that plug-in, I am having filter wheel issues where I can only define 7 of the 8 available slots (the 8th slot is greyed out).

FWIW, I couldn’t get the most recent QSI driver to work for me (as of last spring). An older driver has worked for me, though (version 7.4.1824.0). As far as I can tell, I am not giving up anything by using the older driver and it has been reliable.

I have seen this complaint and resolution from others (also for what its worth).

Best regards,
Craig

Craig,

Did you have an issue using the older driver with the filter wheel. I have loaded the 7.4.1824.0 driver and the camera seems to configure correctly. However, on my 8 position filter wheel, only 7 of the 8 slots are active. The 8th slot is greyed out. Couldn’t figure out what was wrong.

Thanks,

Jerry

Hi Jerry,

I was setting up a new NUC in the early spring. I apologize that I cannot clearly remember the details of the issue I had. I tried to install the latest QSI driver and couldn’t make it work. I vaguely remember multiple cameras or filter wheels listed but none completely worked.

I installed the driver that I mentioned and it is still working for me (I am using it at Okie-Tex star party this week). I actually think I have the same camera as you… a QSI690 with 8 position FW and an OAG port.

Hope you get things worked out.

Craig

Here is a link to the info I have sent on to QSI to look at. I include the SGP log files that show what SGP does when trying to connect to the camera.

No feedback yet.

Hi Jerry,

Been on the road headed back from the star party. I am using that old driver without issue as far as I know. I haven’t upgraded to the 4.* version of SGP, yet. I am running the most recent release of 3. Not sure if that has any impact?

It would be nice if QSI were able to get the newer drivers to work, but I am not sure the older one is hurting me?

Thanks and regards (and good luck),

Craig

I have been working with the distributor and QSI/Atik to try to resolve my issue in connecting my QSI690 to SGP.

QSI/Atik has said that I need to use the ASCOM Camera option. However, in my SGP Equipment Manager there is no ASCOM Camera, I have QSI Camera/FilterWheel and QSI Camera1/FilterWheel1. Here is the feedback I got through the Distributor from QSI/Atik:

“Atik has been able to provide a bit more information on the drivers today; confirming that their main focus is on the ASCOM drivers solely, and as such the support they can provide is for that platform. They have let me know that since this change in direction, applications trying to use the native drivers may not work with the driver packages and plugins released since the focus on ASCOM began. They have let me know however that Sequence Generator Pro should be able to utilize the ASCOM platform; and in fact many of their users connect their QSI or Atik equipment to the program through that platform. Since this doesn’t appear to be showing up for you they would suggest ensuring that you have installed the most recent version of the platform; and if issues persist it may be pertinent to try uninstalling and reinstalling this.”

I have the latest ASCOM platform and NET Framework version installed. I have done a “repair” on the ASCOM installation, but still do not see the ASCOM Camera option in the Equipment Manager for SGP. Should it be there? If so, do you recommend removing and re-installing the ASCOM platform per the recommendation from ATIK/QSI?