ASI 2600 MM lockup

EDIT: Updated with more information based on further testing

I have a ZWO 2600 at a remote site which is unusable when run by SGP due to freezing and locking up, often during autofocus but sometimes during regular images (in the rare cases where it gets that far).

W 10 home fully updated
SGP 4.X fully updated (have tried 32 bit and 64 bit as well as 3.X 32 bit with same result).
Most recent ZWO ASCOM drivers

The first few images download fine but at some point (typically within the first 5 images), it takes maybe 35 seconds instead of the normal 2 or 3 seconds, the next image after that just locks, often followed by the tone that indicates USB has disconnected (but it has not disconnected according to the connection indicator). It then stays locked, never coming out of that state.

This is probably a USB issue of some sort but here is the part about SGP:

It happens in NINA as well but with two big differences:

  1. In NINA it happens much less often and randomly, maybe 2-6 times in a night’s imaging whereas with SGP it happens within the first few minutes, usually during the first focus run.

  2. Most important, with SGP it causes the sequence to freeze and it stays frozen but with NINA it simply takes much longer to download the image (30 sec to 3 minutes or so instead of the normal few seconds). The critical difference is that in NINA it does eventually download a normal image and proceeds with the sequence. With SGP it just locks and continues to say “downloading”. It never leaves that state, it does not move on, there is no error message, nothing.

So is there a problem with the camera or the Pegasus USB hub or the cable? Probably.

But is is equally clear that SGP could be dealing with this better. In NINA it is useable with only minimal inconvenience (you might lose a few minutes a night), in SGP is is simply unusable.