ASI ERROR crashes program

I’m crashing pretty consistently when auto-focusing and sometimes when trying to initiate guiding. The error window displays the following:

Error ‘ASI_ERROR_GENERAL_ERROR’ from call to ASIa(A_0, A_1=o, A_2=0, A_3=False)

Obviously, it’s having some issue with the ASI camera driver. (ASI120MC-S).

All equipment connects without issue, but once i start running a sequence, or sometimes just taking a quick shot, this error pops up, and i can’t dismiss the window. I then have to force-quit and restart.

Also, I’m also having the focus . “failed to move focuser - needs 30 steps” error (i paraphrase.) even though I’ve achieved near-perfect focus with a Bahtinov mask.

Any assistance would be greatly appreciated. Love the software, but it’s unusable at the moment, and I have to fall back to APT, which has none of these issues.

Pegasus FocusCube
SSAG Autoguider

@backintime . Can’t be sure… too many variables. Please reproduce the condition in SGPro and send logs. We can take a look and advise.

Thanks. I’ll log it next time and send it in.

I have started experiencing a similar issue over the past two nights.

Camera: ZWO ASI1600MM Pro with ZWO filter wheel
Mount: Skywatcher EQ6R Pro running EQMOD
SG Pro version:

Both nights, everything worked well for several hours until SG Pro crashed while the sequence was running unattended. First night, crash time was around 3:20am (end of the log), second night crash time 1:10am (end of the log).

Logs are hosted here:

Sequence file:

This is very frustrating as I have made no changes to the system. Any help or suggestions are extremely appreciated.

Thank you!


@Ken or @Jared: Was the ZWO SDK changed between versions and beta I am running the beta version on another imaging system and I have not experienced any of the crashes of the last two nights on I have updated the problem system to and will run again tonight.

So after two more nights of imaging I have made some progress. I tried a ASI183MM Pro to rule out camera trouble and I found the same behavior. It appears that it is due to USB choking. I had the camera connected to a USB3 powered hub together with guide camera, filter wheel, focuser, and EQMOD cable. I connected the camera straight into the computer right next to the mount (short cable, no hub) and for the past two nights, I have not experienced any crashes on download.

the question is: using the ASCOM ZWO ASI driver, one can lower the USB traffic limit. Is it possible to do the same thing with the native driver?



I’m interested in this topic as well, as, I’ve had connection and download issues with my ASI183.

Not quite sure where the problem is, so, I can’t really add any suggestions at this point.

I will follow this conversation closely though.


No, we us a fixed traffic limit in the native driver as to not complicate the driver. But if I recall it is set at 40.

The ASI API has not changed in a long while in SGP…we’re actually due for an upgrade here.


I recently Sent a message to ZWO about my ASI183 camera download and connection issues.

ZWO said " We did not encounter this problem before".
I thought that perhaps the problem was with my camera, though, it appears at least some others have had a similar problem.

One thing ZWO did suggest, was to use a USB2 cable direct to the computer. I haven’t tried this as
yet and will give it a go when the weather clears here.


Thank you, @Jared. I am pretty sure it is a USB traffic issue. I don’t why it hasn’t come up before. I haven’t changed anything on that imaging system for the past six months. It is possible that the USB hub itself may be introducing delays (It’s an industrial Startech USB3 hub, but I don’t know how long these components last out in the dew).

Scott, that’s exactly what solved the problem for me. You can’t really connect a USB2 cable because the camera has a USB3 port, but a short USB3 cable connected directly into the PC at the mount took care of the crashes on download for me.

I too am having the exact same issue (ASI1600, ASI120MC as guide camera) - at auto-focus and at start of guiding (usually when I initiate the PHD2 calibration run).

The ASI1600 doesn’t have the problem as much as my ASI120MC does. Lately PHD2 has been having real problems connecting to and keeping a loop going.

Using a direct to computer option is not good for me as I am too far for a direct connect. I’m using the Startech USB2LAN system, so I have a Cat-5 LAN cable going out to the mount from my PC.

Will be watching this discussion :slight_smile:

Hi Lucam,

The weather has improved here, so, I was trying out v I was still getting the ASI ERROR
problems when trying to take a single Frame and Focus. Also, some download problems during Auto Focus, so, I needed to change something to improve reliability.

With my setup I have a 3m USB Cable going straight from the ASI183mm to a NUC Intel i7 next to the mount. I could try and set a powered Hub on top of the scope as has been suggested.
I think this maybe the best way to minimise some cabling and perhaps get a better download from the camera.

Anyway, at this point I decided to try the ZWO suggestion of a USB2 style printer cable in the USB3
connection in the back of the camera. I was a little surprised as it fitted ok. Then, to the computer via
a USB3 powered hub.

Tried some single frames and noticed the download speed is a little slower, but, not by much. The main thing is that it worked and I had no more issues with crashes, black screen or error messages.

I will try this for a few nights and see if the reliability improves.