ASI1600mm-cool and SGP - white frames!

I’m at an impasse and could use some help.

I’ve been imaging with SGP for a long time and with my ver. 1 ASI1600MM-cool since it originally came out with virtually no problems. I’ve not had much chance to image since last fall and recently updated my ASI and ASCOM camera drivers as well as the latest SGP release. I’m trying to make new dark masters and have the camera on my workbench connected directly to my imaging laptop through the USB 3 port - same configuration as for imaging, and what I’ve used for biases and darks in the past. I have no idea what is going on but at first I would get completely black frames at any of three gain settings (using “ASI camera (1)”, as I always do for imaging). I mean black - no noise, no amp glow, no signal, just black (with or without auto histogram and confirmed in PI). Then, as I change the gain between sets of images (60, 90, 120 seconds etc. per gain setting), the images start coming out pure white. I discovered that if I restart and reconnect SGP and the camera, that I get black frames again, but ANY change to the camera settings in SGP and the frames come out white, unless I restart SGP and reconnect the camera. Then I noticed the camera setting was set on “RAW8”, so I tried RAW16 and voila! I got a few “normal” looking dark frames with amp glow, etc - like I expect for a dark frame. So I tried starting over using the unity setting on the camera set up dialogue (SGP) and RAW16, but I get only white frames. Change it to RAW8 or try different gain settings - re-starting SGP and reconnecting the camera each time - and I get only white frames. I’ve tried 4 different USB cables, including a brand new short cable with not change. USB speed is set at the default 40, but until these new driver updates I’ve always had great luck at up to 80. I’ve also tried the “ZWO camera” option in the SGP camera dialogue box with the same white frame issue.

I’ve occasionally, but rarely, seen the white-frame issue in the past and found it was related to the USB speed setting and always went away when I lowered the USB speed setting to 70. I’ve never used the lower setting of 40, but now any setting above 40 (i.e. 70) results in the unending “downloading” problem.

Any ideas? Is this likely SGP, driver, camera or laptop related?


Just curious here…have you tried downgrading the drivers to what you were using previously, and testing with the old drivers?

I am also curious what version of SGP you were using. Did you also upgrade SGP, or are you still using the version you were using before?

If possible, I would downgrade all versions to what you were using before and try again. Then, upgrade one thing at a time to see if you can narrow down the source of the issue.

Jon, That’s my next step. I did upgrade to the latest SGP as well as the ASCOM camera driver (from ZWO) and ASI drivers. I’m not sure, however, what the last ASI driver was that I had - I avoided updating drivers as the early ones always had an effect on amp glow requiring new darks.


Well, after a half dozen driver changes, cable changes, reinstalling SGP, trying USB2 ports, etc., I figured out the problem. For these bench images, the camera fits nicely on top of an insulated mug I have that I wrap with gaffers tape to seal out light. That works OK, but I forgot to screw on the metal lens cap as the main blocker of light. That’s one way to get back into things after being away for 8 months!