ASI294MM Camera Cooling Hangs

I just received a new ZWO ASI294MM Camera. I was using SGP V3.2. I had the cooling parameters set to cool to -15C in 10 Minutes. However, when it starts to cool the temp hangs at around -1C and the power level is no longer increasing. It just hangs there. I hit about on cooling, and when I disconnect the camera SGP crashes. When I relaunch SGP and connect the camera again, it seems to work correctly. I installed SGP 4.0.0.639 and I get the exact same behavior. I also have ASCOM 6.5SP1 installed along with the latest 9/18/2020 ZWO ASCOM driver. I have tried different power cords, and directly powering the camera and the results are consistent.

A little further troubleshooting showed that this seems to happen the first time launching SGP after a reboot and connecting to the camera the first time. Then after the first SGP crash, I can open SGP without rebooting and it works correctly until I reboot the computer again.

Same thing happened to me last time out!

Version 3.2.0.609.

However, I didn’t catch it until 48 sub frames later. I took them all at a reading of 10.5C when the set temp was -10C. Point is, SGP didn’t freeze up , it took 3.5 hours of sub frames and even did an automated meridian flip before I caught it.

I re-started SGP and regulation worked fine at -10C. But I didn’t take any of the other steps that psparkman took.

I checked previous targets on previous sessions and all the temp regulation was working.

Drop box links to log (pre and post failure) are below:


  • Jim T.

Im unsure what can cause this, but logs showing the issue may help to determine:

More information here https://forum.mainsequencesoftware.com/t/about-the-sgpro-support-category/11086

SGP did continue to operated, even with the camera temp hung. The camera can take images, but just like you, the temp is not what is needed. SGP does not crash until I try to abort the cooling and disconnect the camera. Then, if I restart SGP without rebooting the computer it works fine from that point on until I reboot again. I will do a test and get some logs.

Thanks Ken, I am sorry that I did not submit the error through the Application Report a Problem interface. I did not not know about that capability. I have submitted through that function and included the log file where SGP crashed. I can confirm that issue occurs the first time after a complete power cycle of both the computer and the camera. A reboot without power cycle works as expected.