ASI6200MC Pro image capture and saving intermittent problems


Image captured by ASI6200MC Pro encountered intermittent failure when saving to disk.

Aprox time of issue: 12/06/20 12:42:30.831

Frame 5 of the sequence wasn’t saved to disk.

Link to Logs

Useful Info

OS: Microsoft Windows 10 Pro
.NET: 4.8

ASCOM Platform 6.5
ZWO ASCOM Camera driver
ZWO ASI Camera driver

There’s many of us with the same problem, it’s caused by SGP not handling the large files that well being a 32bit application.
A 64 bit version was promised being weeks away over half a year ago, but there’s still no 64 bit version available so i’m wondering if i should switch to a different software if they cant deliver the 64 but version soon.
I must have lost at least 10 hours of imaging at this point.

1 Like

Also the same problem…
Since, I switched to NINA and all work perfect !

1 Like

The problem isn’t SGP alone to be blamed. The ASCOM Platform 5 and ZWO ASI Camera ASCOM driver appeared to have caused more problems. By rolling back to the previous versions, SGP image download problem reduced from about 1/0 to maybe 1/300+ !!! At least, that’s tolerable and no need to use NINA right now.

We do have an alpha release (private beta) available if you’d like to try it. Getting a version together that works fully with 64-bit drivers has been more problematic than we expedted.

I’d love to try it! I got access to a good amount of different gear to test with too

Not sure why it is believed a 64bit version of SGPro is needed. A 32bit app running on 64bit Windows 10 can access 4 gigabytes of memory. Hard to believe your imaging session needs more memory than that. Download issues are almost always a communications error.

A “dumpbin” analysis of SGPro shows it was compiled to use 4 gig address space:

14C machine (x86)
3 number of sections
5FC184C4 time date stamp Fri Nov 27 16:59:16 2020
0 file pointer to symbol table
0 number of symbols
E0 size of optional header
122 characteristics
Application can handle large (>2GB) addresses
32 bit word machine


I am unsure as well, but this is what I do know. With the 32-bit driver, the camera has a tendency to issue “Out of Memory” exceptions. Slightly misleading it means that the driver was unable to allocate enough contiguous memory to store the image (temporarily one assumes). It does not indicate that the system is low on RAM. I don’t know why it happens and maybe it’s a memory leak in the driver (since it occurs after some time). The reason folks believe the 64-bit driver to be a solution to the issue seems purely anecdotal and is because the issue has occurred in other software applications when using the 32-bit driver and does not seem to occur with the 64-bit driver. Maybe the 64-bit driver has the same issue, but is just less likely to show it over the course of a sequence during a single night. I honestly dont know…

Jared and I discussed the current state of the 64-bit beta and we will be releasing it as a public beta today (unless something goes wrong). Will be available shortly.

And then there are at least some of us like me who use both an ASI6200MM and ASI2600MC in a dual rig on the same computer and have no issues whatsoever with downloads, of course using the ZWO ASCOM driver. Admittedly I had to go through three different USB cables before I found one that worked 100% of the time, but it is possible.

Another data point: for several months I had to connect the ASI6200MM directly to a port on my NUC computer, while the ASI2600MC was connected to a Startech USB3 hub. I had download issues with both cameras if the 6200 was connected to the hub. Recently I switched to a Pegasus Powerbox Advance and I’ve had no download issues with both cameras using the powerbox USB ports.

This is one of the great mysteries in astrophotography…

I would rather call it a great drawback of the USB specification.