ASI6200MM Image Failed to Download


I received the ZWO ASI6200MM Pro camera today. While trying to build a dark library I noticed approximately 10% of images failed to download.

Aprox time of issue: <12:00>

Link to Logs

Useful Info

Intel Core i7 9750H CPU
64-bit Windows 10 Home
Connection to camera is USB 3.0

OS: Microsoft Windows 10 Home
Ver: 1909 (18363.900)
.NET: unknown

Take a look here: ASI6200 Fails to save and plate solve overflow error - SGPro Support - Main Sequence Software

I did not want to accept this as a solution. However, last night after having approximately 30% of my images fail to download again, I turned everything off and gave it a try. I warmed the camera up and parked the mount. Then closed SGP and opened NINA to try for the first time. I had prepared it earlier in the day. I connected everything and started a sequence. NINA ran for several hours with zero “failed to download” images.

I have ordered and tested $75 worth of cables but in the end I went back to my original setup and it worked fine in NINA with the USB cable going from the ASI6200 to my UPB V2 then through my powered 30’ USB 3 extension back to the laptop. Image download time was faster and not a single image failed to download.

I hate changing software and have sold many copies of SGP to new Astrophotography friends. Now, I have to use NINA until this is fixed. Please send out some kind of notification when this issue is resolved so I can come back to my beloved SGP. Thanks Jared and others for all your hard work.


Try reloading the camera drivers. I had the same issue some months ago. It worked, at least in my case. No problems since.


I did try that with the latest driver on two different laptops and my editing PC. All had almost identical results. I’ve switched to NINA now with zero dropped frames without changing anything so I have to go with what works (even if I don’t like it). Hopefully a fix will be available soon!