ASTAP as focus metrics provider not working

Description

I use ASTAP for over a year for plate solving and I am very content with its performance. Lately I wanted to try ASTAP as the focus metrics provider as well, but it didn’t work so far. I use a STC-Duo narrowband Filter with an ASI2600MC Pro (OSC) camera. Exposure time for plate solving is 4 s, for focusing 20 s.

When ASTAP is used as focus metrics provider, the first AF frame is captured, the frame is diplayed with HFD values, but not data point is added to the AutoFocus plot (HFD vs. focus position). The second frame is captured, same result. Then AutoFocus stops. In the appended logfile, this was tried twice, at 23:04 and at 23:07.

When SGP is used as focus metrics provider, the AF process works as expected with otherwise the same AF settings.

Link to Logs

Useful Info

OS: Windows 10 Pro, Version 20H2, Build 19042.867
Ver: 4.0.0.661 beta (64 bit)
ASTAP v0.9.519
ASCOM v6.5.1.3174

Hi, Just a thought, but how up-to-date is your ASTAP install? If you have been using ASTAP for a good while and have not updated then you may have a version that predates the relevant API calls for AF with SGP. I cannot recall the version needed but I am using 0.9.523 and it is working fine for me.

1 Like

Hi Mike,

thank you for your reply. I don’t think it is an outdated ASTAP version, I updated to v 0.9.519 at 01. April 2021. However, I will update to 0.9.523 tomorrow (currently I am imaging using SGP as focus metrics provider).

The really strange thing is: with ASTAP as focus metrics provider, 2 focus frames are captured and displayed; they look perfect to me, the HFD values are displayed - but no data points are included into the focus plot, and then the AF process is aborted.

Bernd

Hi, I took a look at your earlier log and it looked to me that the fault was related to the call from SGP to ASTAP for ASTAP to analyse the AF image.

04/11/21 23:05:09.225][DEBUG][Camera Thread][AF;] ASTAP - Error running auto focus. Error starting ASTAP: Der Prozess muss vor dem Bestimmen der angeforderten Informationen beendet werden.
[04/11/21 23:05:09.225][DEBUG][Camera Thread][AF;] Auto focus HFD calculated at: 0,00 with 0 stars
[04/11/21 23:05:09.225][WARN][Camera Thread][AF;] HFD value from auto focuser is 0!, trying again…
[04/11/21 23:05:09.234][ERROR][Camera Thread][AF;] Auto focus received a bad HFD value 2 times in a row! Something may be wrong! : Auto focus received a bad HFD value 2 times in a row! Something may be wrong!
bei rf.a(AutoFocusData A_0, tm& A_1, tm[] A_2)

: Which made me wonder if it was a problem with your ASTAP version.

I recall that somewhere in the release notes for v4 there was mention of the ASTAP version needed for AF support but at the moment I cannot find it.

Ok, I find this in the SGP release notes from November. If your ASTAP is Apr 21, then ASTAP version should not be the issue unless there has been a problem introduced with a very recent version.

Sequence Generator 4.0.0.636

Additions

A simple warning dialog to ensure users know they are running beta software.
Full support for the offset parameter in ASCOM cameras
Sequence file name can now be used as a file naming token (using %sq).
You can now select ASTAP as the focus metrics provider for Auto Focus (ensure that you have the latest version of ASTAP installed).

Changes

Control panel camera layout supports offset for camera gain settings (paired with gain)
General control panel layout tweaks

Mike, thank you again for your time. The same issue already occurred with SGP v4.0.0.636 Beta, ASTAP v0.9.447 and ASCOM 6.5 RC1 in November 2020.

@Ken
@Jared

I was never able to use ASTAP as focus metrics provider. Please assist!

Could it perhaps be related to the fact that I have set gain and offset only in the ASCOM driver, and not in SGP?

Bernd

Upgrading ASTAP to v0.9.527 (current version) did not help.

Bernd

I tried running several SGP versions with some ASTAP versions including the newest ASTAP 0.9.527. They all worked here in simulation (sky simulator for ASCOM):

SGP
3.2.0.660
4.0.0.635
4.0.0.661

This is something for the SGP team. First thing to try is a restart of the computer.

Han

Hi Han,

I totally agree. I did not suppose that it is due to ASTAP.

@Ken
@Jared

Do you need the sequence file or any other information from me in order to track down the cause of the issue?

Bernd

Seems like the ASTAP process is still running when we’re attempting to call it for subsequent calls. Not entirely sure why this is happening. I’ll have to look into it and see if it’s due to the image size or something around that

Jared

Hi Jared,

do you have any new findings concerning this issue?

Do you need further information?

Bernd

@Jared

Is this issue something that you willl look into?

Bernd