local solver installing


I´m trying to install the local solver following the instructions of this link:

but in all attempts it appears the next message after the 8 point:


could not find the index directory

Any idea?

Thanks in advance!


Could you post a screenshot of the exact error message? Also, please tell use what version of Windows you are running.

You should be able to see the message right away when you run the Index Downloader : Start Menu => Local Solver => Index Downloader. (no need to re-run the installer again at this point)


Hi Andy,

I´m using Windows XP and Idon´t see the message that you say when running the index loader because there isn´t any index downloader!!.

Find attached the screenshot of the error,



Just to add some closure to this thread: Roberto and I worked together to get his ansvr install working.

The installer has problems with the combination of Windows XP and a non-English language setting in Windows. I do not plan on investing much or any time to fix this in general since the non-English XP combination should be very rare. But if anyone else runs into this problem, let me know and we can manually fix it like we did for Roberto.



For your info I run into a similar issue tonight.

I have Win 10 in Finnish language. Everything goes all right untill the Astrometric Index Downloader should be run. The error states no index directory could be found.


Hello Lave,

Sorry you are having trouble downloading the index files. You can download them from Index of /~dstn/4200 . The README file in that location will tell you which index files you need to download.

Save them to the location C:\Users\<YOUR_USERNAME>\AppData\Local\cygwin_ansvr\usr\share\astrometry\data


Hello! I discussed this with Lave earlier over IRC. I think the problem is that in Finnish Windows the Users folder is called Käyttäjät, and there is no cygwin_ansvr folder in C:\Käyttäjät\<USERNAME_HERE>\AppData\Local in the user’s home directory. I didn’t have time to check where the cygwin files actually got installed to.

I’m also facing this issue.
I have Windows 10 French.

I have two accounts, an admin one with admin rights, a user one Eric without admin rights.

After setup download in user account, I ran the setup. It prompted me for admin password that I gave.

At the end of the setup, I checked the option to download indexes. I got an error like


doesn’t exist.

Of course, cygwin is in C:\Users\admin\AppData\Local\cygwin_ansvr\

So I ran IndexManager.exe as admin and it was ok.

But, overall, why is cygwin installed in a specific user folder?
In my case, this means that I can’t use it from an account without admin right.


Indeed, I’m able to use cygwin/ansvr with a user account. First, using File Explorer from the user account, I went to cygwin folder. At some point, Windows prompted me for admin password. I gave it and now, I can permanently go to this folder. I can also use cygwin with a non-admin user account.