Atik EFW2 Fails to report move complete + SGP failed to notify

I have been having a frustrating problem with my Atik EFW2 filter wheel over the last few months. I think it’s the same problem as reported in this thread, but I can’t be 100% sure.

The reason I’m starting a new thread is because last night SGP failed to send me a notification that there was a problem. When this has happened in the past I have gotten a notification that the sequence aborted.

What happens is that SGP calls for a filter change and reports “moving” in the filter wheel module. But it remains “moving” for a long time and causes SGP to abort. Most of the time the filter wheel has correctly moved to the right position but the ASCOM driver/SGP keeps reporting “moving”. On rare times the filter wheel has NOT moved correctly. When this happens, if I shut down SGP and restart SGP the filter wheel position is correctly reported in SGP and I can continue the sequence. Note that I do not disconnect the filter wheel at all, just restart SGP and all is fine.

Based on a suggestion in the above linked thread, I have increased the filter wheel delay to 15sec. I started at 10sec and at first I thought that had solved the issue because it happened much less frequently. But then it happened again and I increased to 15sec. Happened again. So I’m not sure that is a solution.

I have been in conversation with Atik on this. They seem convinced that the problem is that I need a new elastic band around the filter disk. I have no idea why that would be the solution but they are sending me a replacement band (its been in the mail for nearly 3 weeks now!).


Does anyone have any idea what could be causing this?

Why didn’t SGP send me a notification when the sequence aborted, as it has in the past when this problem occurred?

Hi Joel,

I do see this as well. I have not time the delay. I connect the filter wheel manually by clicking the button on the sequencer dialog. It says “Moving…” for a while. If in that time I get impatient and click disconnect and connect, or clock the “settings” option, I get an ASCOM error. If I m patient, the filter wheel eventually responds, in perhaps a minute. The correct filter shows up in the docked filter wheel module of SGP. I will say that I have only imaged with the L filter and have not attempted automated filter changes during a sequence. That could pose a problem.

I see that the Atik developer has not responded to your post on the Atik forum. I also wonder why we have not seen more reports. Is it because fewer people are doing automated filter changes as through SGP? I am a little short of time as I am on my way out to a dark sky site. I’ll help trouble shoot after I return. I’ve attached what log files and images of error dialogs I have at the moment. The ASCOM Atik logfile does not have any entries related to the filterwhwheel.

In the short term, the solution for me is to leave the filter wheel alone while its moving -perhaps increase the delay even more.


sg_logfile_20160731224141.txt (1005.8 KB)
ASCOM.Atik.0442.296200.txt (258.7 KB)

Thanks for the reply Ajay. I also manually connect the filter wheel on the
sequencer window and I never have a problem with the filter wheel
connecting. And also I can go through many filter changes manually, and
some during a running sequence, then suddenly and randomly the filter wheel
(ASCOM? SGP? hardware?) doesn’t respond and SGP aborts.

Atik didn’t respond on the Atik forum, but they have responded to my direct
service request. I know that one other person has brought up this same
concern to Atik and Atik wants us to try a new elastic band. Unfortunately
neither of us have received the new band despite being shipped over 3 weeks
ago. I’ve inspected my elastic band and I sure can’t see anything wrong
with it so I have my doubts. I’m afraid of it being a driver/ASCOM issue,
or worse yet a hardware problem on the PCB in the filter wheel.

It’s worth prompting Atik, maybe something has gone wrong with the shipping. They are usually pretty responsive and I’d start with private messages.

But whatever way you do it, let them know. They can’t be expected to fix problems when they don’t know that they exist.

Yes Chris, I have. Vince has been very responsive. I contacted him last Friday to tell him the replacement band had not arrived yet. He replied that he would have expected it by now and he wanted to check with the other US person who he sent one to, and that person has not received it either. So, customs must think it’s a dangerous package or something! :slight_smile:

I trust developers and manufacturers to know their product better than I do. While I have my doubts about Atik’s solution, I will trust they are correct until I have the opportunity to test it. I’m just getting tired of waiting for a small package that should be here by now.

Chris, I have put in for a support ticket with Atik as well, but I am curious to know if the ASCOM error dialog I posted above means anything to you, or is it a generic, “filterwheel not ready” type of response?


I get this problem from time to time, mostly if I power up the system in the wrong order and it will fail when trying to connect but sometimes will fail in the middle of the night. Mine will say moving but never get the filter. If you disconnect the wheel and try to reconnect it will still just say moving. When I actually put my hand on the wheel, I can tell nothing is moving. If I look at “Devices and Printers” in Windows there is usually an exclamation point over the filter wheel showing it is not functioning.

Mine was checked out by Atik when I had to send in my camera for warranty service and it was fine. Vince told me that the EFW2 filter wheel does not like USB hubs, of any kind, and unpowered hubs are the worst. I could not get it to work at all on the USB hub in my CEM60 mount but it usually works fine in my powered hub. While they will usually work, there will still be random USB failures. If possible, connect the filter wheel directly to the computer’s USB port.


That is unfortunate because so many of us image with laptops which have 2-3 USB ports available. The filterwheel gets its own power from a DC connector. The USB bus is presumably needed only to communicate with the laptop and, for a filterwheel, is the rate at which commands/reports are sent back and forth likely to overwhelm the bus like a camera might? With the almost zero knowledge I have of USB specs, I can’t even speculate how the hub might have an effect. I’ll try connecting directly to a USB port and see if that makes a difference.


It could certainly be USB related. But not using a hub isn’t very practical. I have used this particular EFW2 for over 5 years with at least 3 different hubs. I must admit that this issue may have started around the same time I introduced a new powered USB3.0 hub into the mix. I can’t remember for sure, but I do think it started before that.

It seems like if it was USB related it would happen more often. As it is right now I can go hours with multiple filter changes and then it will randomly fail to report a filter change. I simply can’t see a pattern or trigger that causes it.

@joelshort This is becoming more of an Atik rather than an SGP topic - but I guess no problem keeping it here until we are sure.

Like you I have used the EFW2 for a couple of years without problem (via a powered hub) but of late I have had intermittent stops. Last night, it definitely was the filter wheel that stopped the sequence. Everything just hung waiting for the filter to change. I did not check if it physically had changed already as others experienced - I just shut things down. It was early morning and I was just looking in on the sequence via TeamViewer…I was in no mood to go trouble shooting at 4 a.m. when I had a good idea re what the problem was.

Up until recently - not a problem…and the only thing that has changed is the Atik driver. I think I will clear the updated driver off the system and go back to the old one. I’ll direct Vince to this thread…we can’t all need new rubber rings on our carousels! Like you said though…intermittent problems like this are a bummer to solve…but if I get a run of trouble free nights on the old driver again - I’ll let you know…but that might take a while to prove.

@Kinch You’re right this is probably an Atik issue and I have been in constant communication with Atik about it. But I know there’s folks here who are having the same issue.

I too think this started around the same time as the new Atik drivers started coming out. I thought about rolling back to the older driver, but I couldn’t find where to get it. Can you direct me to the old driver, or can I download it directly from you? I believe there have been a few new revisions lately, so we may need to go back at least 3 months in order to get the older one we were using before.

Just sent you a private message with a link to the 1.1 driver. I too am in contact with Vince - I told him that I first want to try the earlier driver before doing any other tests. I don’t think the problem is with SGP - nothing has been done here lately that might change the interaction with EFW2…at least I don’t think so. Still, I will report any progress or lack of, here, as other guys are now experiencing similar problems.

I received an email messages from Vince and Chris and will respond to their questions shortly. One of the things that Chris told me was that he had found a bug in the previous version of the core software (I think he means July 5 version). he encourages us to upgrade the software and to test the wheel.

Vince says that they have tested a wheel with SGP for 700 position changes and have seen no problems. He does not mention which version of the driver was used. I’ll ask. He also asks if the wheel works with the Artemis Capture. My answer is yes. So this rules out hardware issues. Could some of you please try this as well?

Also Joel Short had initiated a thread on the Atik Forums. We could continue the conversation there. However I suspect other Atik users here will be interested. So unless I hear from a mod that we should move I’ll continue this conversation here.


The new core software on the Atik website is dated July 28. I’ve asked Vince which version of the driver was used in their test. I cannot trouble shoot any more jist now. I’m off to image in a few hours. I’ll take a copy of the core software with me and install it only if I am stymied in the field. I am mostly going to shoot L on this trip and will not be making any filter changes. Not going to take a chance at this point.


Thanks Kinch!

Ajay, it does not surprise me that Vince has been able to test the wheel with SGP for 700 position changes. I can sit there and manually change the filter position all day long too. I never have a problem with that. The problem has only happened during an imaging run.

Last night I increased the filter delay from 15s to 20s and had a successful run all night long. I was shooting LRGB and cycled through events, so every new image required a filter change as well as auto focus and meridian flip. No problems. So this has me wondering if there is too much traffic on the USB line and setting the delay spreads it out more, allowing the communication to complete.

I believe if I get rid of the filter delay the problem will crop up much more quickly. I’ll test that out. I will test with Artemis Capture as well.

Considering I’m a MOD on this forum, in my supreme over-lordship of this forum I will declare that for now this thread is fine. I’m glad to move the discussion over to the Atik forum as well, but I had not received any replies there. Perhaps I will summarize this discussion over there.

I have not tried that one yet - I will do BUT after I have tried the older driver…simply because I am all set to do that tonight. Ajay - do you actually have a version number for the EFW2 driver in that core software package? Just wondering.

I have been using the July 28 driver since it came out. I was hoping that it would solve the problem but it didn’t.

I had updated to the July 5 core software, then the July 28 with equal results.

I don’t have the version number available. I am using the July 5 version as of now. Until later…Clear skies Kinch.


I did a little experiment during the afternoon with the Jul 28 core software. I set up a test sequence of 25*1sec exposures with each of 7 filters and rotated the filter after each exposure. Of course it didn’t have any problems this time so that was 175 rotations without a problem.

Why do you set Filter Delay? Is this not an Ascom compliant FW and should it not be reporting motion completion? I have always left mi delay setting at 0 (zero).

I have stayed with my imaging for the end part of tonight’s run. Later I am going to open a separate thread re some observations. One thing I have noticed: filter change and focus change slowing down drastically as the night goes on. This may just be my set up - not particularly SGP…but if anyone else notices this please say so, in case it is actually SGP.

Getting back to the filters…if things do slow down after hours of imaging (with your set-up also…not just my gear) and the filter wheel takes too long to make an actual change…then perhaps this is when things hang as we have seen…the FW does not actually get around to reporting move complete. I am clutching at straws maybe…this is so hard to nail down. One would have to look very carefully at the log if not watching things as they happen - but it may be evident in black & white.

Just for info - using the older filter wheel driver tonight and no hang or stop in the sequence…just seeing this drastic slow down in filter change as noted above.