Auto focus again

Auto focus
I wonder if someone could have another look at my Logfile. I had a discussion with you regarding this on the 18th Sept. I followed your recommendations but no difference. I have been in contact with Baader (the focuser) and they recommended I increase the power going to the focuser via the USB cable. I have done this with a duel USB adapter. There is still sometimes a delay in the movement, but according to the log it does move to the required position. However after focusing with a mask then switching to auto focus, there are no indications of any focus points in the V curve, just an empty box with the time counting down at the bottom.
I have also been in touch with Starlightxpress, but the camera seems to be ok. And certainly works fine during the initial focusing with the mask.
The telescope is centred on Caph in Cas. so plenty of stars.
As I said in my previous emails it all worked perfectly in the past.
There is a section of the log below, with it all in the dropbox link.
Thanks in advance. Adrian

[07/10/2015 22:05:00] [DEBUG] [Focuser Thread] SGM_FOCUSER_MOVE_REL complete…
[07/10/2015 22:05:09] [DEBUG] [Main Thread] --> Find stars no max stars
[07/10/2015 22:05:11] [DEBUG] [Main Thread] Find Stars: 24 found…
[07/10/2015 22:05:11] [DEBUG] [Main Thread] Star list contains 24 stars…
[07/10/2015 22:05:11] [DEBUG] [Main Thread] Calculating HFR with sample size: 100
[07/10/2015 22:05:11] [DEBUG] [Main Thread] Tried to display solved stars, but list is null
[07/10/2015 22:05:11] [DEBUG] [Camera Thread] ASCOM camera: frame and focus…
[07/10/2015 22:06:06] [DEBUG] [Camera Thread] SetAscomNormalSpeed…
[07/10/2015 22:06:06] [DEBUG] [Camera Thread] Cannot set readout speed, not supported by camera…
[07/10/2015 22:06:06] [DEBUG] [Camera Thread] ASCOM Camera: abort message received…
[07/10/2015 22:06:06] [DEBUG] [Camera Thread] ASCOM Camera: Attempting to abort exposure…
[07/10/2015 22:06:06] [DEBUG] [Camera Thread] ASCOM Camera: Exposure aborted…
[07/10/2015 22:06:07] [DEBUG] [Camera Thread] SGM_FRAME_AND_FOCUS complete…
[07/10/2015 22:06:17] [DEBUG] [Camera Thread] SGM_FOCUSER_AUTO_FOCUS message received…
[07/10/2015 22:06:17] [DEBUG] [Camera Thread] Checking for auto focus…
[07/10/2015 22:06:17] [DEBUG] [Camera Thread] Pause guiding while AF is active, pause command sent, waiting for guider to pause…
[07/10/2015 22:06:17] [DEBUG] [Camera Thread] Tried to pause guider for AF, but failed on timeout, continuing AF anyhow…
[07/10/2015 22:06:17] [DEBUG] [Camera Thread] Auto focus: setting filter Lum
[07/10/2015 22:06:17] [DEBUG] [Camera Thread] Setting filter position 1…
[07/10/2015 22:06:17] [DEBUG] [Camera Thread] Filter position 1 is already set. Skipping…

Hey Adrian,

I’m sorry to hear about your troubles. Can you take a picture of your focus options? I’d like to see them as well. Are already roughly in focus when you start the auto focus routine? How many steps between points and how far in HFR are you stepping out when you run auto focus?


Hi Chris.

Thanks for getting back to me. I am tearing my hair out with
this. And as I said previously I do not think it is an SQpro problem as I have successfully
used it for a few years. I was hoping the logfiles could be interpreted to
show the problem.

The Options box is above. The step size looks high but it is
controlling / driving, the fine focus wheel (10 to 1 ). I manually set it on
the Lum. Filter, it is on 15 sec exposures and when I use Ha it is on 35sec. I
managed one successful focus run in Lum last night but when I tried Ha I had an
empty box for the first two frames (nothing showing at all), then a red cross
on zero one step in from the right then the next frames was on about 5, the
next higher on about 7. Then it sounded like the focuser was just winding out,
and sure enough, it came to rest about 6mm. beyond the approximate focus point.

I have no problems with seeing, little light pollution and
the focus area I am using is high in the sky.

I always use a mask before the focus run. I was not sure
what you meant by ‘how far in HFR are you stepping out when you run Auto Focus’?

Thanks again. Adrian

You’re moving your scope a total of 720 steps to determine where good focus is. What kind of telescope are you using? Do you know where the HFR button is? You should see it on the roll bar near the middle top… Looks like a star. What you want to do is determine your focus at whatever. So my good focus is around HFR 1.5 and it’s at step 2600 on my FSQ106. Then, move out about 100 steps and redo that until you reach about HFR 3. Then, go back to your original focus and move in until you reach about HFR 3. Take the high number and subtract it from the low. In my case I end up with about 360 steps. I want a total of 9 data points… So my steps end up being 40.

I’m 99% sure you’re just moving too much. Let us know how te math works though. I’ll be up tonight if you post.


It’s not unusually large. I set mine to 125 steps for 9 focus points for my Handy Stepper Motor for 3.5" FT focuser (1.3 microns per step) and works fine.


Hi Peter.
Yes I realise it is not a high step number, and as I said it has worked with no problems in the past. I have a new scope on order with a 3.5 FT focuser and posidrive motor I hope that works better. This problem is more complicated. I will give some more detail in my reply to Chris.
Thanks for your input. Adrian

Hi Chris.
The scope is an APM 107 F6.5 refractor with a Baader focuser (Baader filters). You are very lucky having focuser software that retains its location number when it is disconnected. The Baader always defaults to zero (without changing it’s physical position). That would be fine except it will not move in a negative direction e.g. -10, -50 -100. So initial focus has to be set manually by winding the focuser back for say 10mm, then driving it forward with the motor for say 4,000 steps to give it a positive number to work with (good fun all this)! Then I focus with a mask. Last night it focused with the mask at 3,960 steps. I then ran Auto Focus with a Lum filter and managed to get it to work though the HFR was not quite as good as the mask, but not far out. However the step count was 3,794 and if I try it repeatedly, it always decreases by about 200 steps every time I run it. And again in Ha. it was so random it is hard to describe and never worked. I had increased the focuser power supply last night with a duel USB connector and a new powered USB cable (it takes all it’s power from the USB powered Hub).
I will try your suggestion if I can get out tonight but I think it must be some fundamental mechanical problem, is it possible to wear out a stepper motor by winding it thousands of steps manually every time I set it up? I have had it since May 2013, so that’s hundreds of times.
Regards. Adrian

1 Like

I think those stepper motors are very sturdy. They use them in mounts after all! :blush: Give it a try and let us know. That is very frustrating that their software requires you to go to zero each time. You might ask for a change to it? Or, see if Rigel Systems can integrate with your focuser. I actually use a Moonlite stepper with a Rigel focuser controller. I really like it and it’s worked well for 2 years now.

Hi Chris.
I had another go, I managed to auto focus in luminance. It was a lovely night so I set about an RGB sequence. No problem at the start. I checked on the next timed autofocus run, no problem, so I went to bed. I went out to check the meridian flip only to find the third AF run had failed. It had moved the focuser from around 4,000 steps to over 6,000 steps. As I am ‘off axis guiding’ the star was lost and the sequence had aborted. As I said to Peter I have a new scope on order so I am going to give this up. I will have to manage with a mask and an attended Luminance run until I get the FT focuser and Posidrive motor. Too many clear nights going to waste.
Regards. Adrian

OK, you might try a different auto focusing setup too if you like this scope. It sounds like the Baader isn’t very user friendly. You didn’t mention if you tried what I suggested above for figuring out how large of an area you wanted to cover? I still think you’re probably exceeding SGP’s ability to determine focus. It has a relatively small area from about HFR 3 on either side of focus. Obviously if it’s getting outwards of 2000 steps… it’s probably going to far.

Also, try out ‘recovery mode’. It’ will attempt to recover your sequence for a set amount of time. Works pretty well but usually can’t save a bad auto focus run.



I now have Posi-Drive motor and I am currently imaging tonight. So far Posi-Drive works pretty well but I don’t think it’s better or worse than Handy Stepper Motor.

I use 9 focus points and 70 steps for each focus point for auto focus run. I also use 70 steps for backlash compensation as well.


What focuser is this for? Perhaps something like a Moonlite would be a good option?

Posi-Drive motor is only for FeatherTouch focusers.


Thanks Peter.
I have made a note of your settings to give me a starting point when the new gear arrives (should be in November)
Regards. Adrian

Hi Peter.
The new scope when it arrives will have a FeatherTouch 3.5inch focuser with the ‘Focus Boss II’ electronic focusing control with the Posi-drive motor.
Regards. Adrian

Hi Chris.
I do use recovery mode and it has worked quite well with various problems. I have not yet tried your suggestion but the weather forecast is for a bit of cloud tonight so I should be able to try it in the clear spells. I have seen this 2,000 step movement (mentioned below) before, it happens at the end of a failed attempt to auto focus. It just winds out 2,000 steps (approximately) and stops. It would be handy if the program returned the focuser to it’s ‘pre autofocus run position’ if the Auto focus fails. But then I guess this is only happening to me!
The new Feather Touch focuser I have on order, will be on a 160mm F6.5 Refractor. The one with the Baader focuser that I am having the trouble with is a 107mm F6.5 APM.
Regards. Adrian

Right. So, you have two options here. You can a.) figure out how big you can go from HFR3 on each side and do the math as described above. Or, you can b.) turn off Smart focusing. It’s an option in the auto-focus settings. Smart focusing was designed to add focus points on either side of your curve if you don’t get enough data… the problem is that it doesn’t respond well to stars that get too big or if they have donuts (hence the HFR3 numbers).

Basically what happened last night to you was that SGP went ‘hunting’ for focus and eventually failed.

Adrian, once you do the math above, you won’t have focus problems. You just have to do the pre-game work before you image. It shouldn’t take you more than 10-15 minutes.

Good luck!

Thanks, Chris. I much appreciate your advice (and patience).

1 Like

Let me know how it goes. Maybe I’ll be eating my advice :joy:!!!

Hi Chris.

I had a clear spell last night and set about following your recommendations.

I turned off Smart Focusing. But I had to do everything with the mouse.

The movement was playing up again. I click the mouse to move using either
course or fine controls. It may move, or nothing happens, so I might click
again, about 20sec. later it might move twice in quick succession or it might
not. However I did get some results eventually.

                  HFR 1.06 at

3,560 steps. Moving out HFR 2.95 at 4280 steps

Move back into focus with the intention of going the other way.

HFR 1.21 at 3,360 steps. 200
steps difference for 0.15 HFR

It is always about 200 steps difference (less) when I leave focus and
return to it whether it is with the mouse or if I get Lum auto focus to work.

I got stuck at this point, so I did not get any results in the other
direction. The focuser decided it had moved enough for one night!!

As I have said before it used to run all night with no problems. The
next thing to try is reinstalling Baader’s original ASCOM driver. The one I am
using is for Remote Observatories. But even this one used to work.

Regards. Adrian