Auto Focus Initialization Error

I’m getting a “Auto Focus Initialization Error” box when I first open SGPro in both 32bit & 64bit versions.
This happened in both & 9 releases.

I’ve even upgraded my focuser to a Deep Sky Dad AF3 autofocuser and the error persists

Windows11 Pro Ver 23H2 Build 22631.3737

Unfortunately, I am not sure what would cause this off hand, but we can help you track it down if you’d like to reproduce the issue and send us those logs. You can send them to us directly from within SGPro. Additional guidance here:

SGPro - Help

I would love to send them directly. Unfortunately I’ve tried to open SGPro but all I got was a white screen
with the warning box stating Auto Focus Initialization Error then it just terminates.

I have added the both the l Auto Focus Initialization Error and the SGPro failure to load log files as Dropbox links:-

Kind regards


I’m not following this. You are saying that after the AF error you see said white screen and can do nothing else or the white screen appears when you try to use SGPro’s issue submission system?

In either case, neither of those logs appear to show any attempt to run AutoFocus. Are you sure you lined the right ones?

Hi Ken,

Thank you for the prompt replys:

Initially I started SGPro and the Auto Focus Initialization Error prompt appeared as shown on the attachment in my initial post. SGPro loaded normally, but I couldn’t use Auto Focus as it the Auto Focus Initialization Error prompt kept popping up.

Since then I’ve tried to open SGPro and all I’m getting is a white screen together with the Auto Focus Initialization Error prompt and then SGPro terminates

Ah, OK, I understand now. Do you normally use an AutoFocus metrics provider other than SGPro. For instance, maybe ASTAP or Pinpoint?

Hi Ken,

The only other software I use is Voyager’s robofocus when I have the twin scopes imaging, No issues with the focusing routine.

The reason I ask is that the sequence you are using requires pinpoint for autofocus and I’m wondering if that’s intentional and if you have Pinpoint installed (and if you do if it is still licensed). See here in AF settings:


Since you cannot open SGPro right now, I think all you’d have to do is rename the sequence that SGPro is trying to open on start.

Hi Ken,

Cannot understand how Pinpoint got involved I haven’t since MaximDL v5. Got to be 10 years ago.

Yes I’ll change a sequence and see if it runs ok.

Thanks for your help

Kind regards


Hi Ken,

Renaming the Profile in both 32 bit & 64 bit versions unfortunately still result in a blank screen and immediately close. Tried other profiles results in the same behaviour


It’s not the profile you need to rename it’s the sequence that SGPro is trying top open when it starts

Got it, thanks Ken