Auto focus uses the vertical line imperfection on chip

The autofocus routine is using a vertical line imperfection in my chip to add many false points to the median plot calculation. Is there any way to have the autofocus routine avoid the imperfection? Many thanks. Rick.

I have the same problem with one of my cameras.
I use the nebulosity slider to reduce the number of false stars.


Same here. I’m using the Crop function to avoid the use of that column.

Yes. Two methods have already been identified above. If SGPro is picking up junk like hot columns, pixels, or other noise it is usually because not enough real data exists. So… you can either:

  • Not focus through narrowband filters (not saying you are… just general advice because this behavior will happen almost every time if you do)
  • Increase your exposure time to reveal more stars

If there is lots of real star data, the junk will normally get de-prioritized.

If neither of these work for you (truly star poor area or too much exposure time required for an adequate number of stars), there are a couple of levers.

  • HFR sample size: SGPro will attempt to average 100 stars to determine HFR. If there are only 20-25 real stars, the rest of the 100 will be populated off of your hot column. You can adjust this parameter in real time with frame and focus to observe its effects (be sure to turn HFR on). For this fictitious area of the sky, you would reduce the sample size until boxes stopped appearing on your hot column.
  • Nebulosity rejection: Not really intended to solve this issue, but if people are using it… to each their own.
  • Cropping: If the column is near an edge this is certainly a good option too.
1 Like

Also airplane or satellite streaks can confuse AF. Happened to me once and AF selected many points of airplane streak so I click on “Run Again” button and all is well. But if I was asleep, I would never had caught it and possibly the focus would have been incorrect until the next delta temperature gets triggered.