Autocenter not working on Paramount MX+

When autocentering, the scope slews to target, solves, then tries to nudge onto target, but nothing happens on that nudge or subsequent ones. The mount doesn’t move. Any ideas? I note that essentially an identical issues was discussed in this thread, but I’m not sure I understand the solution there. My log is here:

I’m completely new to the Paramount, or any GEM, for that matter, but I’ve been using SGP since it came out. On the plus side, the auto meridian flip seemed to work out just fine. My very first meridian flip, automated or otherwise. :slight_smile:
Kevin

This bit of log may show what’s happening (or not happening)

[09/24/17 23:06:23.585][DEBUG] [Telescope Thread] Telescope: Syncing to J2000 RA: 22.621790409012 Dec: 34.4087643814928
[09/24/17 23:06:23.585][DEBUG] [Telescope Thread] Telescope: Sync behavior set to “Sync”…
[09/24/17 23:06:23.585][DEBUG] [Telescope Thread] Telescope: Telescope does not support sync, not syncing.

Sync isn’t implemented so the position doesn’t change. AIUI SB don’t allow syncing because it messes up the TPoint mount model.

One of the non sync centring options may help.

Thanks Chris. The options I see in Control Panel>Telescope>Sync Behavior are Sync, Scope Offset, Target Offset and None. I’m not quite sure what the middle two do, and the documentation doesn’t show them yet. Any idea? BTW, I tried Target Offset this morning, and the scope did seem to keep nudging this time, but it was getting farther off target, not closer. Does “inhibit sync to protect TPoint model” also have an effect? Log is here:

Kevin

You need to ask SB about this.

The behaviour of a mount controlled through the ASCOM driver, then TheSky is complex and very difficult to predict because it depends on the mount and what functionality SB has implemented.

The options in the driver settings are only suggestions and will be updated as a result of what actually happens - maybe. Part of the problem is that there are no capability functions in the SB external interface so no way to know what works without trying it and hoping that if it isn’t implemented an error will be reported.

The last I heard was that, as I said, SB had disabled external sync control with their mounts but appear still to allow it if you are controlling a non SB mount through TSX.

I wrote the ASCOM driver interface for SB but had to give up supporting it some time ago because it wasn’t practical for me to maintain it. I don’t have a SB mount.

Thanks Chris. I’ll try to talk to SB.

In the meantime, can anyone tell me how you’re getting your Paramount to work with SGP? The problem for me isn’t the slew, it’s the subsequent “nudging” onto target. From some research, it seems that SB changed TSX about a year ago in some way that prevents that nudge from happening. Are other people getting around this simply because the initial slew is perfectly on target, so no nudging is necessary? I have a moving mirror SCT, so the initial slew for me is unlikely to be perfect.

Astrovienna - use ‘target offset’. That works with my MX. As Chris says, SB removed sync capability for Paramount owners last year some time and I think the ‘scope offset’ isn’t implemented right now.

Thanks Buzz. I’ll keep trying that. BTW, does your setup actually require additional nudges after the slew to target? If so, that gives me some cause for hope that I can get mine to do the same.

Kevin

Yes. Use “target offset”. Works great on my MX+. Usually the second try gets it right on but I’m using an SCT so my model is not all that accurate due to mirror shift. When I use a Newt or refractor, it sometimes gets it on the first try. If you use any other sync behavior in SGP, the mount will never get any closer to center.

Chris

Thanks Chris, that’s great to know. I did have a few minutes yesterday to use Target Offset, but I found it was nudging the scope away from the target, not toward it. But it was all very rushed, as dawn was coming on fast. I’ll check my settings and give it a try again.

I have a TPoint model that is about 4 arc seconds - but I’m using a RCT, so if I do small collimation changes, it shifts the image. I am normally within a few pixels after 1 or 2 iterations in SGP. If I don’t have TPoint, the initial pointing accuracy is about 100 arc seconds (with accurate timebase and polar alignment).

Before SB removed the sync capability (build 9334?) I would get within a few pixels on the first iteration.

Thanks for the help, Buzz and Chris. Do you use “inhibit sync to protect TPoint model?” I didn’t at first tonight. I used Target Offset in the telescope control panel, and it successfully nudged onto target, so that’s a huge relief. But PS2 always fails (ANSVR gets called on the blind solve and succeeds). I assume the TPoint model I made the other night got corrupted, but I have no idea how. Also, after the meridan flip SGP called up PHD2 and move commands were backwards. Not an SGP issue, I assume, but if you know how to fix that I’d love to hear it.

Kevin

Kevin - yes, tick the inhibit sync button to be on the safe side. If I recall correctly, if you don’t, it messes up the TPoint.
If your guiding is back to front after a meridian flip - you need to go into PHD2 brain and check/uncheck the reverse box. I cannot remember which way round it is but using ST4 and Pulse guiding have a different setting for guide polarity after meridian flip.

Thanks Buzz. Yes, that worked. Autocenter and meridian flips seem to be working fine now. I love always getting successful solves in PS2. It’s amazingly fast.

One last question: rotator. To make sure SGP/PHD2 stay with the same guide star post-flip, I need to do the following:

  1. In SGP Target Settings, I need to check Always next to “rotate camera to …”
  2. In PHD2, I need to leave “reverse dec after meridian flip” checked
    When the flip happens, SGP will do the flip, plate solve, then turn the rotator 180 degrees and solve again. PHD2 will then pick up the same guide star and start guiding, with correct directions; All correct? Anything else I need to do?

Edit: Hmm. There’s some discussion of this in the SGP documentation here:

http://www.mainsequencesoftware.com/Content/SGPHelp/SequenceGeneratorPro.html?TelescopesMounts.html

But it refers to a “rotate camera” setting in the Meridian Flip Options that doesn’t seem to exist. Any ideas?

Kevin

1 Like

Well, I tried it again tonight, and it’s working fine. The mount flips, the rotator does a 180, the guide star is picked up again and the sequence picks up right where it left off. It’s great when it all works just right. Thanks to everyone for the help.

Kevin