Autofocus is not detecting stars

I’ve upgraded to the latest version of SGP and unfortunately the auto focus has stopped working.

The initial focus point has good focus, and the focus motor is working fine but no stars are detected by the software and the graph just stays at zero.

I’ve tried adjusting nebula rejection, sample size and exposure length. It was all fine before the upgrade.

Many thanks, Matt.

I should mention it was just clouding over when I took the second screenshot which is why there is so few stars visible and I tried with a without smart focus eneabled.

Hi there,

Please see this post with instructions on how to ask for help (AFPacks would help here if you can produce them).

Many thanks for the input, I’ll get some log files next time I’m out as I’m clouded out now. I was hoping it was something stupid I’d done which the screenshots would reveal.

Log file attached, I’ll post a AFpack tomorrow.
sg_logfile_20150319194747.txt (137.8 KB)

I had something similar happen with a beta and had to turn the sample size way down to get it to work. Pretty much a spring problem, I suspect…

Thanks for that, the above screenshot is as low as I went if memory serves. I’ll try lower at the next opportunity.

Thankyou all, turning the sample size right down did the trick. Problem solved.

OK. This still sounds like a bug to me. You should not have to use the sample size to get stars to show up. If anyone can produce an AFPack with this behavior, we will look into it.

I’m clouded out tonight but I’ll try to reproduce the problem at the first opportunity.

Could I also say thank you for the update, you’ve added some excellent features and remedied some minor niggles.

Thanks again, Matt.

I have stared to have a problem with the focusing with the new version and before it was great and always worked well. I am posting this here because it looks like the same problem.

I set it on a focus run, it takes an image and plots the point on the graph at 0, and keeps doing this for a few tries, just adding points to the zero. After a few of these points it changes the focus further out and repeats the process, each plot is on the zero. Again after a few attempts it moves the focus point even further out, and it seems to do this till I cancel.

While it is doing this, there are no stars selected on the screen and therefore no measurements made.

The only way to get it to focus is to close down SGP and re-run, usually it then works. But even when it has worked, a bit later it fails again and a re-start of SGP is needed.

I started to make a AF pack, but all it was doing was saving lots of these blank images, which would have been a huge file size so I stopped it.

The images displayed on screen initially show out of focus stars as you would normally get (but without the measurements) And as it goes on those stars get more and more out of focus.

The initial focus is being done right after a manual focus with a Bahtinov mask. So it does start off in focus.

Using Windows 7, and there are plenty of stars in the image.



I failed to replicate the problem last night, autofocus worked well all night. If the problem reoccurs I’ll upload a log and link to an AFpack.

The new feature of extending the focus points if there are too few for the return pass is excellent.

I’m using Windows 8.1 and an Atik 314l+

It sounds to me like your images are not being downloaded properly. What camera are you using? Are you using a USB hub? Have you changed any USB cables? Have you recently updated any camera drivers or firmware? I have seen something like this happen when trying to download short images, even when the longer exposures download fine.

When this happens with an AF run, before you shut down SGP, can you take a longer exposure image from the main window and have it download properly?

That’s my guess (???) but it will be helpful to see a log and AF packs.