Autofocus routine failed on SGP v3.1


I was running SGP v3.1.0.457 using a Primalucelab Esatto 3" focuser and have been running it for a few months now. It worked flawlessly. I’m using a powered industrial USB hub.

Last night the OAT was pretty stable so I went and checked the ‘perform autofocus after 10 frames’, normally I use a 1 degree drop. I did a manual start of the focus routine, because it hadn’t done this for 2 hours already.
About 15 minutes after this SGP happened to have done an autofocus routine (not sure why, probably detected it hadn’t focused the last 10 frames), but this happened:

  • Error in auto focus! Focuser failed to move to the requested position (656935). Focuser reports it is at 635935.

This morning I found SGP still trying to auto focus and no data had been collected for the remainder of the night. I had to shut down SGP by task manager because the focuser window was stuck and could not be closed. By restarting SGP I reconnected to the focuser and tried moving the focuser to another position by manual input. This worked without a problem.

Could anyone shed some light on this what could have caused this?
I updated to the latest SGP v3 version today.

Ps. this focuser does not need calibration because it’s a standalone (non pinion rack version).

Best regards,