AVX mount and NexRemote

I was hoping someone could help me out connecting my AVX to SGP. My big question is whether to use NexRemote. The only way I can get it to connect is to attach the serial cable to the HC and then to the computer. If I try to use NexRemote, SGP won’t connect to the mount. The com port box in the ascom driver settings window does not show an open com. If I close NexRemote it will allow me to select a com port. Am I missing something?

It’s been a long time since I owned a Celestron mount. If I remember correctly, there should be a “Virtual Comm Port” somewhere displayed on NexRemote, set it to any Comm port number that’s not defined in your PC’s device manager. And then set the same Virtual Comm Port number in your ASCOM driver. I am not sure if this will work because SGP didn’t exists at the time I owned a Celestron mount. Try set it to COM5, COM6 or COM7.

SGP didn’t exists back then but I was using Stellarium at the time and I needed to set the “Virtual Comm Port” number in NexRemote and set this same comm port number in Stellarium and it worked. It allowed me to control Celestron mount from Stellarium.

Since you already made NexRemote to work with your PC, this means you must have set the “real” comm port number in NexRemote to match the PC’s hardware comm port number. Now, you need another comm port number for SGP to communicate with your Celestron mount via ASCOM driver which is why NexRemote added a “Virtual Comm Port”.


I use my AVX with SGP. I could never get any kind of connectivity to SGP with NexRemote. I use the AVX ASCOM driver. I don’t think that NexRemote can connect at the same time you are trying to use the ASCOM driver.

Anyway the ASCOM driver works great - plate solving and centering, meridian flips, the works. Plus, PhD2 works great with the ASCOM driver simultaneously with SGP. I have not had a problem with this setup. Well, to be honest, you do need to connect through the physical hand control and I did break my home made cable (twice). Other than that no issues.

Oh I didn’t mention - I get connectivity to SGP, ASCOM guiding with PhD2, and simultaneous connection to “The Sky” with the ASCOM driver. I couldn’t be happier with the seamless operation (again except for breaking my cable twice).

Jim T.

1 Like

Thanks Peter! I’ve been able to use NexRemote with Stellarium in the past but I cannot get NexRemote to work with SGP.


Jim, this is what I expected. For telescope connectivity in SGP I use the ASCOM driver which is connected through my HC using the serial/USB cable. The only reason I was trying to connect NexRemote was for telescope control. What version of The Sky do you use? Student? Serious? Professional? So you use The Sky and never touch the HC? can you still use the HC?


I use NexRemote with SGP all the time (although with a CGE Pro, not AVX). In fact, I can’t recall ever using SGP without using NexRemote. It should work just fine. As mentioned above, you need to connect NexRemote first, then set up a Virtual Comm port when you connect NexRemote and then set the Celestron ASCOM driver to point to the com port selected when the Virtual Comm port was set up.


I use the old version 5. I use the HC when I power up the mount to set
index marks date time etc. and go to a sync star. After that, I never
touch the hand control. I slew to the night’s object via The Sky
interface. I think this would work with any ASCOM compliant planetarium
program. And yes, I can still use the HC if I want to.

Jim Thommes

Where did you find “AVX ASCOM driver”? The only NexStar ASCOM driver I can find is Celestron Unified ASCOM driver at:


Scroll down and look for Celestron Unified (6.0.5978, May 2016).


After further investigation, I think it would be easier to download a free software called “Stellarium Scope”. This is an interface between Stellarium and ASCOM mount driver. I believe that’s what I was using to allow me to use Stellarium and PHD2 at the same time with Celestron NexStar mount.

Click on “Stellarium Scope” tab. It’s not intuitive at first but once you get the hang of it, it’s easy to use. Use the following keyboard commands:

Ctrl-1 - Slew to object selected on Stellarium
Ctrl-3 - Sync on the object
Ctrl-5 - Emergency stop slewing

I am currently using Stellarium and Stellarium Scope to control my Astro-Physics A-P1100GTO mount.


I have NexRemote, SGPro, and Stellarium are working together. Here’s what I do,

start NexRemote

  1. Select Com 5 (This is the COM port my mount is setup for)
  2. Select Celestron Mount type (I have two mounts CGE-Pro and a CGEM-DX so depending on the mount I used. I assume NexRemote has the AVX mount listed. If not than you will not be able to run your mount with NexRemote)
  3. Virtual Port (I use Com15 (I like having the 5 so I can remember that my mount is on Com5 and the virtual port is Com15)
    Once this is done and NexRemote fires up. it will show COM15 in the Virtual point window at the bottom of the NexRemote image. It will also, this is cool, populate the Celestron ASOM driver with the Virtual COM port number for you.
  4. Now start up SGPro - Select your Celestron Mount and you should now be able to connect to your mount via the virtual Com15 port.
  5. now You’ll need to do a one time setup in Stellarium
    A. Go to Configuration in Stellarium and find the Plug-in tab. at the bottom of the Plug-in tab you’ll find Telescope Control
    B. Check “Load at startup” and select Configure
    C. Next select the add button then keep the radio Button "Stellarium Directly through a serial port"
    B Type in a name for you scope. I use either CGE or CGEM
    C Keep the connect on delay at ,50s and the J2000
    D. Serial port, type in your Virtual port. In my case I use Com15
    E. Keep the Local host at the default
    F. Hit OK and you should see your mount name in the Telescopes window box. Hightlight and select start.

You should now see your scope indicator in the main Stellarium window. If you do you did everything correctly and now you should be able to remotely slew your mount simply by selecting you target in Stellarium and pressing the control key and 1 at the same time and the mount will move to what you selected.

I hope I didn’t miss a step. Also for the first time you may need to shut Stellarium down and restart.

Hope this helps.

You don’t need nexremote. Just the Celestron ASCOME driver.

It’s my understanding that all Celestron mounts using NexStar are required to be initialized by either Hand Controller or NexRemote first before ASCOM can be used.

In other words, you cannot power up Celestron mount and initiate a slew with third party software like Stellarium via ASCOM without first initializing the mount with either HC or NexRemote. By initializing NexStar mount is done by aligning at least one star with HC or NexRemote in order for the mount to begin tracking.


Yes, that is correct. I forgot that step. With the way I’m setup I simply do a “quick align” with NexRemote. Once aligned I can use either Stellirum to point the mount or let SGPro do the slew to, plate solving and centering. Typically I use Stellarium to move the mount to the target. This gets me close. I then start my sequence and let SGPro do the rest.


Sorry, I was very imprecise in my use of the term “AVX ASCOM driver”. I
am using Celestron Unified (6.0.5412, Feb 2015). Yes I am behind in
updates. So yes, other than it being a more recent version, what you
have in your link below is what I use for an “AVX ASCOM Driver”.

If you are trying to connect to a very down version of The Sky (like I
am using version 5 owing to my old laptops operating Win XP), then the
set up is a bit obscure - you need the TeleAPI plugin for The Sky. In
The Sky, you DO NOT select “NexStar 5…” in the telescope setup dialog

  • instead you select “Telescope API” (once you have installed the
    plugin). see this link:


Once I did that I got seamless connectivity with SGP, PhD2, and The Sky
5 - all simultaneously. I know I am on a bit of shaky ground here since
neither Software Bisque, Main Sequence, or Microsoft support Win XP any
longer. But I have to say that even though XP is not directly supported,
the folks at Main Sequence did remove the install block for XP back in
SGP version (thanks guys). I do have plans to upgrade laptops
and get on Win 7 or later but I am having such stable SGP operation
along with the functions I need from SGP that I am not in a big hurry to
upgrade. I suppose one day there will be a new feature that I really
want in SGP and need to upgrade my hardware and OS, but until then, I am
a happy camper.

Jim Thommes

Just discovered this old thread. I’m using NexRemote with a CGE along with Phd2 and SGP. This works most of the time, but I have had instances where NexRemote seems to freeze, and I have to shut down and start over. So far my only remedial measure was putting contact cleaner on all the USB connections, but that didn’t solve the problem. Win 10 OS.

In the 15 years of operating the CGE, I have never gone the route of connecting to the base of the hardware HC. I wonder if that would help?

I’m rather new with SGP, but it is impressive! So far it won’t do a meridian flip, but I can live East of the meridian.



Make sure that you are using the latest version of the Celestron unified ASCOM driver. I never connected my CGE Pro through the HC, so I can’t help you there. Might be worth a try though.


Hi Bill,

Just an data point. Like Tim, I never used the CGE-Pro HC either. I connect my mount to the computer via USB to Serial cable via a powered USB hub. I use Celestron NexRemote on two different setups. One using the CGE-Pro Mount, along with PHD2 and SGP. For the other setup I use a CGEM-DX mount, along with PHD2 and SGP each on their own Windows 10 OS computer. I’ve never had an issue with the NexRemote. I run all of my equipment, Mount, Camera, Guide Camera, Rotator and Focuser through a powered USB hub and have never had any issues with this setup. On the CGEM-DX setup up, my computer I use is 60 feet away and I run through a USB extender cable from the powered hub to the computer.

It seems to me if NexRemote is freezing, it has lost the connection/communication to/from the mount. Seems like it might be hardware related. The only thing that comes to mind, Do you have the OS/BIOS configured so the USB ports on the computer DO NOT power down? I have seen comments from folks on this forum that you want/need to ensure the USB ports stay active and not power down to save power.

Just my thoughts, Hope this helps you in finding the issue or gives you some idea on how you may reconfigure your setup.

Kind Regards,

Hi Mark,

Many thanks for your response. My imaging programs are running on an Intel NUC box, which is a new thing for me. It is connected to the mount via a 15ft USB cable and serial-USB adapter. I communicate with the NUC via a LAN link and Remote Desktop on an old desktop pc in my office.

I’m not a knowledgeable computer guy, but I took a look at the BIOS and could find only the option to enable/disable the USB ports, and nothing about power options , but I agree with your analysis that the mount/pc connection must have been dropped.

Oh well, it all works most of the time!


Hi Bill,

Funny your setup sounds almost identical to mind. For my observatory PC, I also run a NUC and remote in from my home office via the LAN link. I use Splashtop for my remote in. Great minds think alike :). The one difference is that I have two USB hubs. I have one USB 3.0 hub mounted on top of my scope and I control things like the rotator, focuser, cameras via this USB hub. a lot less cables to get tangled with. and I have another hub, USB 2.0 setting right next to the NUC and I have the mount plugged into that hub along with with things like security cameras.Both hubs are powered.

I think you may need to look at the power settings in the Windows 10 OS. I believe you’ll find the USB power option there. I can’t remember where in the OS the power options are but maybe you can Google it and you might find something. I’m currently imaging and I don’t want to mess with the computer while it is imaging. Maybe someone can jump in to help and point you to where to look?

The one thing I did notice i your reply is that you did not mention using a powered USB hub.


Hi again, Mark,

I’m too impatient to give complete answers like you do…your detailed replies are much appreciated !

We are more similar than you know, as I also have two powered hubs: one on the scope and the other at the base of the pier, with connections similar to yours. I don’t have a rotator, but SGP issues good instructions for manual rotation and I manage with that.

We live in a terrible location for astronomy; I’m 100 miles north of Seattle, looking at the lights of Vancouver, BC. My backyard OB sits on the north side of a hill which blocks my view of the southern celestial sphere, and the skies are nearly always cloudy. But somehow I manage to have a good time with this challenging hobby.

I no longer have a long FL scope, and just try to be content with a short FL refractor. I’m too old and too broke to do this for much longer, so if my mount breaks down, I’ll revert to occasional visual observations. Fingers crossed that I’ll be good for another year or two.