Beta Camera Connection Problem

I get the following error when trying to connect my ASI camera:

Error connecting to ASI Camera (1)! Method not found: ‘int32 ASCOM.DriverAccess.Camera.get_Offset()’.

I rolled back to 3.2 and all is well.

Also, I tried to report this with the reporting system with attached log and that failed too.

Here’s the log file.


I also just tried v4.0.0.639 and got the same error related to get_Offset() with my QSI683. Using ASCOM 6.4 SP1.

I rolled back to v4.0.0.617, which works.


Thx, no need for log files. I swear I have protected against this issue, but I’ll look again. The issue stems from not having the latest version of ASCOM installed, but 6.4 should work just fine.

With all the problems that ASCOM 6.5 had I am very reluctant to update to 6.5 until it has been thoroughly vetted.

It would be nice if the 6.4 SP1 download were still available on the main web site. Even with 6.5 SP1 released, there may be many older ASCOM drivers that are not going to play well with 6.5.

None of my gear needs anything in 6.5, so it will be a while before I consider updating to 6.5.


I had the same problem.


Just wondering if the v4.0.0.639 “get_Offset()” issue for ASCOM v6.4 users has been resolved?


I am having trouble understanding why this issue is still observed with the 639 version of the beta. I may have fixed it, but, if not, there should be enough logging to figure out why. Attempted fix in

Have the same issue “Int32 ASCOM.DriverAccess.Camera.get_Offset()” with Atik 460EX. and latest ver.4. Had to roll back to 3.2
It needs to be addressed,

This should be addressed in the latest ( This was caused by an issue in the ASCOM 6.5 libraries which was addressed in 6.5 SP1 (what links against). If you’re seeing this in please provide logs so we can take a look.


Sadly, it looks like it’s not. I’ll dig in a little more and try and understand why the ascom interfaces aren’t handling this…


Let us know when it is fixed.
Thank you.