Blueastro Stick Station, TEMPerHUM and stuff like this

Hi all,

As of today, the full ASCOM driver with multi-client support is posted on my web site ( Along with the driver is a new version of the Windows application that supports connection to the stick automatically as before, to a specified COM-port, and through ASCOM. Using the latter approach is the way to go so that you reap the benefits of both my Windows application’s data storage and GUI, and Sequence Generator Pro - and any other ASCOM application that supports the Observing Conditions interface.
There is also a new firmware that improves the application’s ability to accurately detect the firmware version.


Thank you Per ! Downloaded and installed, now to trying it out

Hmm…not working for me atm Per. It shows an ASCOM connection in the little app but no measurement values and SGPro does not report values either. The app works if I select direct connection, I have uninstalled the ASCOM drivers and reinstalled but still no go so off to do what no sys admin generally does which is consult the manual. I can PM you if needed.

Suddenly it sprang into life … hmm strange ! I started SGPro first and connected to the ASCOM observing conditions hub and values appeared, I then started up the mini app and it also was now displaying values. I hate not being able to explain why something does not work so it could be a case of PEBKAC but I think something seems off here.

If you consult the manual (;)) you will note that a change of connection method requires an application restart… This is due to some quirks with the .NET serial port class implementation and proper release and I am trying to work around it. So, for now you have to restart if you change from serial to ASCOM… Sorry about that.


Per, I did do a full app/system restart … honest guv.

I’ll look into it…

I had the same problem as @gingergeek with the stickstation - showed up in SGP (via ASCOM observing conditions hub) but not working via the windows app (with ASCOM driver). Noted that the previous install did not clear from windows - two instances visible in Control Panel/Programs. Cleared all and re-installed the newest…now all working fine with ASCOM driver - can see the info in SGP Environment Data module, Temperature also showing up in my RoboFocus docking module AND can run the windows app (with ASCOM driver) and it shows up there now also.
Hope that helps somebody.

I have created a new web page on the site where issues and workarounds are listed :slight_smile:



the temperature of the environment (blue Astro Stick) is not used in Focus Control
SGP Version =
Ascom Stickstation Version =

what am I doing wrong?


I’m wondering if you can’t have the Blueastro app open at the same time… which would typically be the case…

You need to instruct SGPro to use it (instead of the focus controller temp)… “Use environment device for temperature input”.

Probably? Never tried this… depends on if the ASCOM driver and app are designed to share the device.

Yes, you can see on the screenshot :slight_smile:
closed Blueastro app same problem :frowning2:

I missed that part of the screenshot somehow.

Please see here and we’ll take a look:

sorry my english not so gut

I have new insights
When I use a focus simulator, then the displays the temperature in the SGP focus view
When activate my Ascom focus, the environment themerature not work

have you an idea?

I think it works for me - you not only need to set the focuser properties as mentioned above but if you want to see the graph at the same time, you need to use the latest version of Per’s application. This connects via ASCOM hub, rather than a direct link - which locks out other applications from seeing data.

I’ll double check - if I remove the cable from my focuser, it should still read the stick temperature value.

Just to add some pics to what @buzz has said:

On the equipment drop down list…select Ascom Observing Conditions Hub

In the settings for the hub select your BlueAstro Stickstation for the temperature, humidity etc…

…and as you have already done…tick environment device check box in the focuser properties.

Ok, have it tested on another PC
with the Beta v2.6.0.8 it works :slight_smile:
v2.5.1.17 it does not work
is ok for me, I update :wink:
Many thanks!

Right. Sorry, I forgot this was one of the issues addressed in 2.6.

I sell a weather station with ASCOM support for Sequence Generator PRO with sky meter and cloud sensor including a relay option to control an observatory and or alarm. This product is called a SMP-PRO and is very reasonably priced. I also, sell focusers with ASCOM support as well called CFS-PRO. The links are listed below. Email me at for any questions.

Dale DiDomenico