Bug ( - Plate Solve Error

I just got a plate solve error. I’m using the online Astrometry.net. Here are the exact steps I took:

  1. Open SGP, let it create new sequence
  2. Open Target Config
  3. Next to Reference Data, clicked Browse, and selected my plate solve JPEG file
  4. Input my scale of 4.789 just like always
  5. Clicked Solve - got an error “No reference image selected!”
  6. Clicked Blind Solve for the heck of it - no error, solved in about 12 seconds.

No matter what I do, it won’t do a normal solve, it will only do a blind solve.


We won’t be of much help unless we can take a look at the logs. Please see this post for more info:

The image itself will also be required in this case. Dropbox or similar is fine.

Here you go. Contains the log file and the plate solve JPEG file.



Thanks. Might be an issue with JPG files. Another user just filed this same issue yesterday.

It was working in the previous version. I haven’t changed my workflow at all. I should also mention that it gives the “No reference image selected!” error IMMEDIATELY when I press the “Solve” button - no delay.

Can you clarify “previous”? Was that 2.3 or one of the 2.4 betas?

My apologies - I did not use any of the beta versions. My previous version was 2.3.

This is verified broken in the 2.4 release. You will need to convert JPG (or other) images to FITS to use blind solve (until the next release of 2.4.0)

Actually, blind solve is working properly - it’s the regular solve that isn’t working with JPEG files.

Yes, I’m mixing bugs. Blind solve for JPGs is broken from the right click menu. You will need to reselect the image from the browse menu or solve will not work properly.

Not sure if I should jump in here or start another post but downloaded 2.4 and had no luck solving at all last night and gave up.
Downloaded and tried blind solving a previous image (fits format from a dslr) and my Local astronomy net fails almost immediately.
Any suggestions??
Here is a snip of the ansvr data.

This thread is fine since it’s really the same issue. These issues are caused by one of 3 things:

  • Poor data
  • Improper settings
  • Bugs in code

If you can provide the reference image you are trying to solve we can at least eliminate 1 and 3 (or pinpoint them).


Although a screenshot of half a page of the log is not much to go on, and I have no idea whether this is related to your problem, I do notice that you have put in some values for “Solver Extra Args” in the ansvr settings page.
-r this is the same as using the checkbox “sort stars…”, why not just use the checkbox?
--objs 1000 this is the same as the “Objects:” setting, so why not use that?
-H 2.5 -L 1.50 these are the most problematic. SGP will rescale images before submitting them to the solver, and if the rescaling done by SGP results in a scale that falls outside these bounds your solves will likely fail. I would strongly advise removing those from “Solver extra args”.

The other thing that is suggested from the screenshot is apparently no image was submitted to ansvr for solving. Is SGP configured to use ansvr? I could be wrong about this because we cannot see the whole log file. If you want to post the full log file it can be found on your machine at: C:\Users\YOUR_USERNAME\AppData\Local\cygwin_ansvr\var\tmp\platesolve\ansvr-DATE-TIME.log


OK thanks guys. I’m currently away with iffy net connection. I’ll upload log files plus image this evening when i get home.

It appears its not seeing the server but I don’t know why as I haven’t changed anything between updates
links to image and log file

Hi Dave,

Thanks for posting the ansvr log. The log does not show any image being submitted for solving. Do you have SGP setup to use ansvr (step 14 of the instructions http://adgsoftware.com/ansvr/)?


When ANSVR is properly receiving data from SGPro, I cannot get a true blind solve to work on this image, but ANSVR does try until it times out. That said, if I pass in a scale of 1.99" and give scale a 5% tolerance, it will solve in about 80 seconds.

Yes I have Andy hence my confusion.
it has worked fine up until I installed 2.4.

Actually I have found the problem though I don’t know how it has occurred.
Checked the setting under “other” and instead of reading … :8080/api it read :8080/api/config
At no point have I added the /config but I have since removed it an ran the blind solve and it worked in 26 seconds.
No idea as to how the /config bit got added but at least its solved.
Thanks as always for the prompt responses.

Glad you figured it out!

Yes Ken I have a 5% tolerance set in the ansvr settings as I only get timed out failures if I dont.
I have 5% tolerance and 2 and downsample factor set as standard in the ansvr settings as per Andy’s section 12 of the install instructions.
Do I need to change any of these for 2.4 version?
The extra solve arguments are to speed the solve up and have worked fine in the past.