Calibration Frames Run Out of Order

I have used the calibration wizard for years to add events to an existing sequence for Flats, Dark Flats and Darks.

Never had an issue until a few months ago after installing an update after which the sequence runs one image from each event and cycles through the events rather than run all images in an event before moving to the next event.

So, it takes a Flat, then tells me to remove light box for a dark flat, then takes a Dark, then goes back to take the next flat.

I’m not aware of having changed any settings and the sequence settings look ok to me in that they are set to complete each event before moving to the next event - also I don’t have this problem with lights, they still run the full event before moving to the next.

I work around it by only having one event ticked at a time. Don’t know if its a bug or something I have done. I have some screen shots showing settings and the issue actually happening if you need them.

Aprox time of issue: 12/04/2020 c10:15

Link to Logs

Useful Info

OS: Microsoft Windows 10 Home
.NET: 4.8

I think I have identified the issue - partly user error however I suspect a default seting has changed in a non logical way.

It seems that the “Finish Entire Events First” is the default for Lights , and I think used to be also for Calibration Frames. However when I now set up calibration frames using the wizard the setting defaults to “Rotate Through Events” - which doesn’t work because you have to remove the light box each time it switches between the Flats and Dark_Flats events.

Hmm, yes, this appears to be the case. I’ll address this.