Camera disconnects after Take One no download



Strange/first time problem here - set up last night for some imaging. All systems appeared to be working. Attempted a Take One and at some point after the exposure finished, I heard the little Windows alert - di da dup and a message flashed onscreen that the camera had disconnected (see link below). SGP hung on Downloading and nothing appeared on the screen. Repeated same second attempt. I shut everything off and loaded ASI Deep Sky imaging and captured a perfect image - the camera was indeed connected. Shut down all programs, turned off computer, switched USB port for camera input and tried again - same result - immediately upon completing the Take One sequence, i.e., it was a 90 sec exposure and it ran thru 90 seconds, the camera disconnected and the image failed to download. Repeated shut down, swapped USB cables, restarted, but failed again. At no point could I get an image to download or get the camera to stay connected using either Take One or Platesolve. I have all the logs from the session here - I had started with 4.x, but that was no go, so switched to old and reliable 3.x, also no go. Love to get any suggestions and thanks for any help.

Dropbox - - Simplify your life log files

Dropbox - IMG_2744.JPG - Simplify your life screen shot of failure

It’s hard to tell for sure becuase the issue seems to be in the ASCOM driver and SGPro does not have much visibility there. The last we hear from the camera is this:

[03/05/23 18:57:07.334][DEBUG][Camera Thread][NONE] ASCOM Camera: exposure complete, waiting for camera to report image ready...

And, alas, the camera never does report ready (complete). I would start by installing the latest versions of both SGPro and the ASI ASCOM driver. If that yields the same results, you may need to involve ZWO. In either case, they will need to see the camera logs to help trace the issue. Further guidance on collecting logs for misbehaving gear is here.

I had the same issue last night (3/14) using the latest build of v3 (and ZWO drivers 3.19 and ASCOM 6.5.6 which I’d used for months with APT). After SGP failed to take a picture I tried with Astrophotography Tool and NINA. Neither of them worked. At that point it looked like possibly a corrupted driver issue so I downloaded and installed the latest ZWO drivers (native 3.21 and ASCOM At that point I was able to continue with NINA (trying to pin down focus step size). I did not try with SGP due to limited time. I suspect I would need to load the x86 driver to work with SGP v3. I’m not sure the ZWO x86 and x64 drivers can coexist or if SGP would be able to choose the correct one.