Cannot auto-stretch image

Normally you can right click on a new image, and give it a low/medium/high stretch. This works if I am using just my Windows 10 laptop.

I now use an external monitor attached to my laptop with “extended desktop”. Typically I have the SGP main window on my laptop, and the Sequencer window up on the external monitor. With this setup, when I right click the image and move the mouse over to “autostretch-medium” (or any other stretch option), I get rapidly flashing “mouse-over help” popping up and disappearing. I have to try to do the stretch 5-6 times before it takes.

If I drag the sequencer window over to my laptop screen, then the autostretch works as expected.

Related question: where do you set the default stretch for new images? I saw that setup once, but can’t remember where it was.

I tried to recreate this issue, but was unable. We develop on multi-monitor systems so it was pretty easy to try a variety of different things to try and recreate this issue. Sorry we can’t be more help there.

Look in the histogram module (the little arrow next to “Auto Stretch”)


I still get that flickering mouse-over help in I will get '454 and try it.

I still get the same thing with version '454.

I noticed that when the Sequencer window is on my laptop, the mouse-over help is BELOW the menu item where I am choosing my stretch. Pic here.

When the Sequencer window is on my external (second) monitor, the mouse-over help is ON TOP OF the menu item where I am choosing my stretch. Pic here.

I am running Windows 10. My displays on the laptop are set to “extend displays”. My second monitor is on a HDMI port. I actually have a HDMI splitter attached to my laptop, and the two outputs go to (a) a monitor out by my telescope, and (b) a monitor sitting beside my laptop.

With that “splitter” maybe Windows can’t 100% tell what the external monitor is, since HDMI is designed to be point-to-point.

EDIT: by the way the mouse-over-help says “strech”.

Closing due to inactivity. If this is still an issue, please send the requested information and “uncheck” this thread as solved.