Cannot run flats only without deselecting safety monitor

I tried to capture flats with scope in parked position facing my flats panel (roof closed) as a new target (“Calib”) within an existing sequence. No other targets or events were selected apart from just Flats. Sequence aborted after saying conditions unsafe (reported from environment sensors). I have to go through options panel and deselect safety monitor etc for the flats only sequence to run. Is there a way round this?

Link to Logs

Approx time of issue: 29/09/2022 10:11

Useful Info

OS: Microsoft Windows 10 Home
Ver: (64-bit)
.NET: 4.8

The problem here is the we cant assume flat frames dont need safety monitoring. The best way around this might be to make a new equipment profile for your flat frames that modify your sequence such that it is disabled. Then either apply the new profile to the sequence before you start (maybe more steps than just disabling the monitor?) or keep your flat frames in a different sequence.

As a note, AutoFlats addresses this issue and provides an option in the UI that bypasses safety monitoring. It will be out in the 4.3 beta.