Canon 700d Exposure Issue


I have been testing SGP with my canon 700d and I don’t seem to be able to do an exposure greater than 1/10s. If I select 10m it will take 10mins, but the file info says 1/10s. If I go the other way and set 0s I will get a 1/4000s exposure, the fastest the 700d will do. The filenames are correct for the settings I have used, just seems like the software doesn’t think the 700d will expose longer than 1/10s. The download times for the exposures after completion also seems very slow, the canon software or APT takes about 5s, SGP takes about 30s.

is the image preview always greyscale, or is there an option for colour?



Hi Ben,

I am no Canon expert, but this sound like it might be an on-camera settings issue (although if it is working in APT, maybe not). I don’t suppose you know what version of the canon API APT is using. We can check on that if you don’t. Maybe others with this model will chime in.

In the meantime, please have a look here and we can see if something looks strange:

You can get color only for Frame and Focus images (by checking the JPG Preview box). For normal capture of light frames, however, there is no need to grab color images (since SGPro is only a capture program). You can get a RAW CR2 file or you can get a CR2 converted to FITS.

Hi Ken, thanks for the quick reply. I don’t know which api apt uses, but i do know the 700d is digic 5 and apt supports that.

There doesn’t seem many settings to change, i have the camera in manual mode and set to bulb.


I have been testing further and it seems to be related to the mirror settle time. if I don’t use the mirror lockup on the camera and mirror settle time option in SGP it seems to work fine.


Interesting. I wonder if Mirror Settle is handled differently in that camera? I’m assuming you have mirror lockup turned on in the camera when the value in SGP is greater than 0?

Can you send the logs over? They may be useful here.


Could be. I have also tried a fresh install on a different computer and the results are the same.
here are the steps taken to produce the attached logfile,

  1. turned on mirror lockup on camera
  2. ran SGP
  3. plugged in camera
  4. selected canon eos
  5. changed mirror settle time to 2s
  6. connected to device
  7. changed exposure to 10s
  8. ran sequence
  9. closed SGP

sg_logfile_20150414171954.txt (60.9 KB)

I have managed to test this with another 700d and a 600d with a fresh install on a different laptop, almost the same results. the 700d was the same issue, the 600d gave a maximum exposure of 1s rather than 1/10s.

could I be doing something wrong? or are you able to replicate the fault?



The solution of your issue is given in Canon EOS 700D Manual as follow:
Lock the exposure into place after you’ve set it on the camera.
Switching your metering to centre-weighted. This will mean that greater emphasis is put on exposing the centre of the image correctly.
dial in some exposure compensation