Canon DSLR camera failures with

I loaded the release version 2 days ago and on both nights my sequence aborted prematurely due to failure of the camera:

3/26/2015 4:07:01 AM] [DEBUG] [Sequence Thread] Distance stayed below 1 for 5 seconds, done settiling…
[3/26/2015 4:07:01 AM] [DEBUG] [Sequence Thread] Auto guider has settled…
[3/26/2015 4:07:01 AM] [DEBUG] [Sequence Thread] Finished sending frame capture. Entering wait mode…
[3/26/2015 4:07:01 AM] [DEBUG] [Camera Thread] SGM_CAMERA_CAPTURE message received…
[3/26/2015 4:07:07 AM] [DEBUG] [Camera Thread] Canon: Error in PropID_SaveTo. Error: EDS_ERR_DEVICE_BUSY
[3/26/2015 4:07:07 AM] [DEBUG] [Camera Thread] Error while attempting to capture frame…
[3/26/2015 4:07:07 AM] [DEBUG] [Sequence Thread] Run event requested sequence abort…
[3/26/2015 4:07:07 AM] [DEBUG] [Sequence Thread] Clearing timed monitoring events…
[3/26/2015 4:07:07 AM] [DEBUG] [Sequence Thread] Checking RunEndOfSequenceEquipmentOptions, force = True
[3/26/2015 4:07:07 AM] [DEBUG] [Sequence Thread] In RunEndOfSequenceEquipmentOptions
[3/26/2015 4:07:07 AM] [DEBUG] [Main Thread] Canon: PropertyEventHandler: event 101, property 406, parameter 0,
[3/26/2015 4:07:07 AM] [DEBUG] [Main Thread] Canon: PropertyEventHandler: event 102, property 41B, parameter 0,
[3/26/2015 4:07:08 AM] [DEBUG] [Canon Download Thread] Canon: Directory Item Requested Transfer
[3/26/2015 4:07:08 AM] [DEBUG] [Canon Download Thread] – Event delay: 0 ms
[3/26/2015 4:07:10 AM] [DEBUG] [Main Thread] Canon: PropertyEventHandler: event 102, property 41B, parameter 0,
[3/26/2015 4:07:10 AM] [DEBUG] [Canon Download Thread] --------------> getCapturedItem time: 1782 ms
[3/26/2015 4:07:38 AM] [DEBUG] [Sequence Thread] Stopping auto guiding…
[3/26/2015 4:07:38 AM] [DEBUG] [Sequence Thread] Attempting to stop PHD2 guiding…
[3/26/2015 4:07:38 AM] [DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Pre-Wait : Guiding
[3/26/2015 4:07:38 AM] [DEBUG] [Sequence Thread] Sending to PHD2:
{“method”: “get_app_state”, “id”: 1001}

sg_logfile_20150325212021.txt (1.6 MB)
sg_logfile_20150324201708.txt (931.7 KB)

I’ve included both night’s logs.There was a loss of guide star. SGP recentered, focused successfully and then tried to take the next image but got the device busy error. I don’t know if it is conincidence or not but the failure on the night before also occurred after an autofocus run.

When I got up in the morning and saw what the failure was I had frame and focus take an image which worked. The image was downloaded from the camera as expected.


We are not able to, with certainty, track this down to a single issue. Research on the internet suggests implementing an automatic retry mechanism so that;s what we did. If when you attempt to take an exposure, the device reports it is busy, SGPro will wait for up to 10 seconds for it to resolve this state and then continue.


What about a longer interval (30-60 sec) or does it keep retrying if it gets the busy message again? Or would a longer interval not matter? I can’t say I’ve actually watched it happen so I don’t know how long it would take for the camera to recover.

A couple of days ago, the sequence ran all night without problems so it definitely is a hard one. Maybe it’s just my camera just flaking out.


I’m not sure… we’ll play it by ear and see if it continues to happen. I’m not sure why it happens so I don’t know if or when the busy state will clear.