Canon: eds_err_invalid_handle

Last night I was imaging and I got an EDS_ERR_INVALID_HANDLE error twice. The first time it happened, I was actually up and monitoring the system, so I was able to continue the sequence. Important note - I was able to continue the sequence without actually disconnecting the camera - so I don’t know what the error actually means.

I am using SGP Version and I am using the latest beta PHD as recommended by SGP.

Below is a link to my log file. If you search for 1:55:01 AM you will see the error. This error eventually caused my sequence to abort, and I lost about 2 hours of imaging time. I should also note that, accidentally, I did NOT have the recovery mode active. That being said:

  1. Exactly what is this error and why did it happen?
  2. Would SGP have recovered and continued the sequence had I turned the recovery mode on?

Thank you. Log link is below.


I am not really sure what it means specifically. In general, it means that the camera has lost connection with the SDK.

  • Was you camera at an odd orientation when it disconnected?
  • Do you have your camera connected though a hub?

SGPro will not attempt to recover from what is perceives as hardware failure (we just stick to trying to recover from possible changes in environment and maybe some network communication stuff).

This was before the official release of 2.5. You should no longer be using PHD2 betas… although I doubt if it has anything to do with this issue.

So I’m assuming that the Invalid Handle is perceived by SGP as a hardware rather than a software failure, and that SGP would NOT have attempted a re-connection no matter what. However, since I was able to immediately resume the sequence (since I was sitting right there) with no other steps, it seems like this is a software issue to me. To answer your questions, however:

My camera actually sits inside of a custom-made camera cooler box. The cords go in through a small hole and are secured, both to the camera itself and to the outside of the camera body. My camera was pointed at M80 at the same of disconnection, meaning that it was pointed fairly low to the South (I’m at 36 Deg North). During the first disconnection, I was imaging M56, meaning the scope was pointed straight up. Either way, I secure my cords so that there is no torquing at the connection point.

I have two USB devices connected at the scope level - my Canon T3i and my SSAG guide camera. To connect them, I have a 16-foot dual-head USB active repeater cable from Sewell Direct. It has worked beautifully this entire time. I’ve never had my guide camera lose connection.

So going back to the beginning of this particular post - I’m still assuming that SGP would NOT have tried to recover from this error. With the new notification system, would I have at least been notified of a problem?

Thank you for your help.

This is true.