Canon EOS Ra

Any word when SGP will support the Canon EOS Ra (or R) camera?

Not yet… we are working on CR3 support, but we are having to do it by hand as no raw libraries have released support for them in a format that is directly compatible with .NET.

We have an alpha release ready which updates the Canon libraries and includes a new Raw processor. If you’d like to test it out and report back you can find it here:

https://www.dropbox.com/s/2yibs6mdpjooeij/Sequence%20Generator%20Pro%203.1.0.461.exe?dl=1

Thank you,
Jared

1 Like

Jared, I downloaded the program and tried it out. I used a WiFi connection to my Canon EOS Ra and ran 2 sets of 10 images making flats, each set taken after starting the program. This is the first time I’ve used SGP so I may have made mistakes, but I believe It largely worked. The only exception is that the brightness of the first image in each of the 2 sequences is significantly dimmer than the other 9. I can’t tell why. All the images were taken with a light panel and should be identical.

Not necessarily… some panels take a period of 3 to 4 minutes to come to full brightness.

I don’t think that can explain what was happening. The light panel was turned on several minutes before either test and remained on between the two runs.

I tried the alpha with my EOS RP and was successful! Camera connected without problem and was able to take a (non-astro) sequence with the CR2 option selected. Whether these are CR2 or CR3 files, I’m not sure; however, I was able to read them into both Adobe Bridge 2020 (and then to ACR) and into PixInsight (and was able to debayer said images).
This is very encouraging, thank you for your work on this.
Regards
Mike

Those would be CR3. That option needs to change to indicate that it’s either “FITs” or “Whatever format the camera gives us”. In a less wordy version.

Glad it’s working!
Jared

Good job, Jared and Ken!!!

The first tests with my EOS Ra were successful! - Thanks a lot !!

I tested with ‘Frame and Focus’ and all options work as expected.
Also a sequence with FITS and/or CR2 worked well.

There is one feature which I miss that would be very helpful for uncooled cameras:
In the exif data of the raw files is the parameter ‘Camera Temperature’ which records the sensor temp. Could you please add this to the fits file as well? Or pass its value to paramter %ct so that it can be recorded with the filename. This would help very much with calibrating.

Again, thanks a lot for your work on this!
Regards, Peter

That should already be working. I’ll see if something has regressed there.

Thank you,
Jared

I tried out the alpha release with a Canon EOS RP. I might be doing something wrong, but it throws an error when trying to ‘connect’ to the camera.

Can you post a log?

RP is the one of the cameras I’ve actually tested this with so not sure what could be up with that.

Thanks,
Jared

Did you put the camera in bulb mode? I had the same error until I did that. Also, make sure the Canon EOS utilty is closed if it had opened up when you connected the camera.

Is Canon Ra support exclusive for Version 461 so far? Connecting to the camera worked quite well with that version for me, however, if disconnecting and reconnecting several times throughout one session, reconnection does not work anymore at some point, for no obvious reason. After upgrading to version 479, camera connection does not work anymore at all.

CS Wolfgang

I’m using the R, and not the Ra, and also using 461. When I try 479 it doesn’t work for me either.

R/Ra/Rp support is only available in the 461 “trial” release at the moment. I hope to get some additional testing in later this week and merge the Canon support into the main line SGP release.

Jared