Canon error

I am getting an error when plate solving “getcaptureditem” the appropriate directory ect ect being used by another process
I have nothing else running, checked msconfig ect. nothing visible.

I do have BYEOS installed, but not running, any ideas?



Peter, Please see this post:

Using SG on a 64 bit Win 8.1 Dell I7

link to logfile:

I have my plate solve exposure set to 10s using a Canon 60Da.

When I command a center in target dialog box the shutter opens for possibly 1-2 sec and then shuts.

I get this error in a red dialog box.

“Canon: Error in GetCapturedItem. The process cannot access the file C:\Users|Peter\AppData\Local|SequenceGenerator\canonRaw.tmp because it is being used by another process.” I click OK

The Center target process continues. I get an immediate plate solve failure, then after a few minutes using the blind solve fallover? it too fails.

I could find no reference to this error in the help file.

I was not running a sequence only trying to center.
After searching the help file once again, I attempted to run a sequence with a single light exposure at 240 sec.
The mirror/shutter activated for about 1-2 seconds and then shut.
SGP indicated that an exposure was being taken (green progress bar) for 240 secs
At the end of the sequence I had a single light frame that had been exposed for about 1-2 secs

There are plate solve exposures in the appropriate directory.

Hope this provides enough info.

Thank you


Perfect Peter. Thanks. We’ll take a look shortly.

Thank you, I have more logfiles if needed.

I also feel I should mention that I took 12 4 minute exposures immediately after I threw in the towel (for tonight) on SGP with BYEOS, no issiues

Yes, thanks for the additional information. Unfortunately the log only appears that SGP was opened and closed. I think this is the incorrect log. Can you look in your log folder and try to find the correct one based on the time this occurred?


For an easy test (and possible fix) can you try deleting the file it’s complaining about and restarting your machine? Maybe something has it locked and it’s letting go.


Here is another logfile.

I am back in for the night. I did delete the offending file and got the same error.
I then tried another center with a target selected and got the same 1-2 second exposure with a launch into plate solving.

It seems to be a camera issue, it is not taking the specified durations.

I tried to run another sequence but had no guider and was using the simulator for the telescope.So no joy there, I would expect the same result , a very short exposure

I have restarted my machine twice.


That log is also nearly empty. Maybe you can just zip up all the logs in that folder and I can take a look. Maybe you can give me a date and time when this happened to help narrow things down.


More files

On a hunch, I uninstalled SGP and reinstalled Beta 2681.
log 5222 attempted center now with no error, but only a 1-2 sec exposure was taken
Terminated the target center process by clicking “done” (nothing was going to happen)

log 0208 attempted single light frame sequence Got the immediate getCapturedItem dialog after a 1-2 sec exposure

log 0953 attempted target center Got the immediate GetCapturedItem dialog after a 1-2 sec exposure, terminated sequence, keep in mind SGP thinks it is doing a 10sec exposure or a light frame exposure. I do not think it knows the shutter closed immediately.
Deleted .tmp file ref in dialog box

log 1511 attempted target center, same as before, GetCapturedItem dialog.

I guess it is obvious that after the first failure with no error, something happens that is not good.

Canon EOS 60Da firmware 1.1.1
Maybe we can get something from all this?

Maybe I can borrow someone’s CCD camera and see if that works ?

Thanks for all your attention to this, I hope this is not one of those Win 8.1 “anomalies”


Trying again on the files, first link only points to a single file


Update; 2/2/15 @ 1520
Attached ATIK 383L worked as advertised, all good
Attached modded Canon 60d using firmware 1.1.1
Same behavior and errors as my 60Da.

Seems like it is doing a frame and focus, went to frame and focus and upped the exposure to 10 seconds, still only exposed 1-2 seconds and threw the error.


Not sure what’s going on here Peter. I also have a 60D and this is what SGP is actually developed against for Canon…so it works well. You have the camera in Bulb (B) mode correct?


Yes I do, this is odd. Looks like it is definitely something on my end if it works for you.
I do have the Canon utility installed, maybe there is a conflict there. (not running)

I installed just the utility from the DVD as Maxim required that when I was trying it out.
I have uninstalled Maxim as I do not intend to use it.

Maybe there is something left in the Registry that is causing this??

I do not see any resident or startup items calling for anything.


Do you have a lens attached? Is the lens in manual mode?


No, no lens

Have you tried 2.3?

Are you using the “Mirror Settle” in 2.4? Do you have “Mirror Settle” enabled in your camera?


What about USB hubs? Anything involved like that or do you have a direct connection with the computer via USB? If so, have you swapped out your USB cables? Likely won’t make a difference since you said other software seems to operate you camera without issue.

Mirror settle or lockup is disabled in the camera.
I have tried this with and without hubs, right now I am sitting at my desk with just the camera hooked up to my laptop.
I had mirror settle at 2, I have lowered that to “empty”

AND, that seems to have fixed it. How about that.

I did a 10 sec frame and focus, 60 sec sequence, and a 5 sec sequence with a lens in man focus
all good.

Thank you ver


You had this set in SGP and NOT in the camera? Yes, that would certainly explain it. If you want to use mirror settle you MUST enable it in camera and in SGP (non-zero value). These cannot be out of sync as it will cause the exposure to essentially become your mirror settle time. Here’s what happens when mirror settle is enabled in both:

  1. SGP Sents a shutter press
  2. The camera lifts the mirror but leaves the shutter closed.
  3. SGP waits for your “Mirror Settle” Time.
  4. SGP sends another shutter press
  5. The camera fires the shutter.
  6. SGP waits for your exposure time
  7. SGP “lifts” the shutter stopping the bulb exposure.

So by having it enabled in SGP and not in the camera you only got through step 5 before SGP was notified by the camera that there was an image ready to download. Essentially step 1 opened the shutter and step 5 closed it.

From the 2.4 docs: