Canon550D issue


<Hi all, I have a big issue with my canon550D about images taken with sgpro. Everything was working perfectly since last month but now suddenly, without having changed anything in my setup, I can’t get readable images. What I mean is that the images taken are with few stars and nothing else as if it were a filter blocking the light to my camera. I tried to take the same picture with same iso and same duration with another program (APT) and the image was ok (the galaxy was showing); taking the picture at the same object with the same parameters with sgpro, nothing is showing but only few stars. I can’t really understand what happened since I did not change anything, but now I have this kind of issue. I tried to install again the program (even with previus version instead of the latest one) but no change. Any idea?

Link to Logs

Useful Info

OS: <windows 10>
Ver: <Sgpro>

I forgot to put the two images, one taken with SGPro the other with apt

This is just a guess as no log is included. But I’m assuming maybe you have the mirror settle enabled in SGP but NOT in the camera. Therefore your actual exposure time is just whatever you have setup as your mirror settle?



Hi Jared,

I will give it a try. The only thing strange to me is why that happened even if I did not change anything either in SGPro and the camera itself?

I tried listening to the “click” sound of the mirror while taking shoots and seems like now is flipping and getting the right exposure.

I will see tonight if it works… if not I twill try to get the log file from SGPro and I will ask you help again…

So far, thanx for your help,


Some other apps will change the mirror lock settings of the camera and leave them in that state. SGP does not control the the mirror lock, nor do we check the state of it on the camera. So my guess is that these two things are not setup correctly.

Thank you,