Can't connect Canon 70D in SGP

Just setting up SGP and trying to connect to a Canon 70D but it won’t. I also have Backyard EOS which I have been using and I can connect just fine to this same camera in that program. Any ideas why SGP won’t connect?


I guess no one else is using a 70D and has connection problems? Interesting enough I discovered I was able to get SGP to connect to the 70D if I first used BYE to connect and disconnect to the 70D. Then SGP connected to the 70D just fine. I have to try and repeat this to see if it holds true but I did find that interesting.

SGP gives me an error incorrect mode, please set to manual. Which is funny because I was using SGP and the 70D last night via bulb mode (once I got it connected somehow) and it worked fine. I come back tonight and reconnect, having changed nothing, and SGP says can’t connect. Thats when I tried using BYE to connect (test things) it was able to. Then I went back to SGP and tried connecting again and then it did. Very weird. I just bought SGP yesterday. I was expecting some kind of support response by now seeing other posts answered after I posted this. Anyhow, hopefully someone has some ideas I can try. I’m still troubleshooting myself in the mean time.


Shawn - I just wrote a similar note on the 60D - I had the camera on M and not B. Putting it on B fixed it. Nebulosity worked with the camera on M.
hope that is it

Yes, for cameras that have a “Bulb” mode you should be using that. I’ll revise the error.


Hi guys and thanks for helping. I do have it on bulb mode for SGP. That’s how I’ve always used it with BYE. I’m going to experiment more today with it. Sorry dumb question, but where is the SGP log? I was hoping to provide it so someone could look and see if it reveals any useful info why SGP isn’t connecting to the 70D, consistently anyhow.

Thanks again.

You can find the SGP log location under the "Help’ menu in SGP. Be aware that every time you start SGP a new log is created so there will be several in the folder. These get purged after 7 days.


OK. Here’s the log

It doesn’t really tell me much about the camera connect problem.

However, I am repeatedly not able to connect to the 70D when I start SGP and try.

If I close SGP and start BYE and connect to the 70D, then disconnect, close BYE, start SGP again, I am then able to connect to the 70D.

I have repeated this several times now and it’s the only way for me to get SGP to connect to the 70D. A little odd.

If I didn’t have BYE I may not be able to connect at all? Hmmm.

Any other ideas to fix this let me know. I haven’t got a clue. I am using the correct mode (bulb).

Thank you.

All it says is this"

Please set camera dial to "Manual"  Error: EDS_ERR_PROPERTIES_MISMATCH

But “Manual” or “Bulb” should be acceptable (with bulb being preferred). If you set the camera to Manual and attempt to connect does it work? If you set it to Bulb and attempt to connect does it work?

We may need to add a check for the 70D to allow it to connect in Bulb if Manual works.


I agree the log does not reveal much.

Manual mode does not work. Bulb does not work.

I can only connect in bulb but I first have to connect to the 70D using BYE, then disconnect, then connect to the 70D using SGP.

That is the only way it will connect in SGP.


Hi Shawn,
I do not have 70D or BYE but do have a 6D and the EOS utility installed.
When the camera was plugged in the EOS utility automatically started grabbing the camera driver thus not making it available to any other capture software including SGP.
However in the EOS utility it is possible to disable this function and so when the camera is connected the EOS utility is not started thus making it available for SGP.
Just wondered if BYE is automatically starting when the camera is plugged in and preventing SGP from seeing the camera.

Hi Bob - good point.

I am making sure the EOS util is not running. BYE actually won’t connect to the Canon if EOS util is running. So in this case of SGP not connecting to the 70D, it is not the EOS util interfering.

Thanks for the input though on this. I’m hoping to get this solved sometime soon. Been longer getting possible fix than I expected.


Well I’ll start by saying I am disappointed that this problem was not followed up on. I am puzzled by this. I purchased the SGP in good faith, encountered a problem and attempted to find a fix for it here on the forum. 2 weeks later this thread is still not responded to. Left for dead it appears. The good news in this is that I fixed whatever the problem was myself with no help from SGP staff and can now connect to SGP without first having to launch BYE, connect, disconnect and then connect in SGP to the Canon 70D. It’s a great program I think based on working with it a few times now but the service/support was lack luster. Hopefully future support requests will see improvement.


I am curious Shawn about what the problem turned out to be. What did you do to fix it?

Sorry, sometimes things fall through the cracks. To be honest I probably wouldn’t have been able to offer much assistance. My 60D is working just fine as is my 6D and we don’t have a 70D to test with. I likely would have recommended attempting to swap out the EDSDK.dll that was shipped with BYEOS to see if that addressed the issue.

Glad you got it working.