Capturing flats issue_Report a problem_Second try with the logs


Link to Logs

Useful Info

OS: Microsoft Windows 10 Pro
.NET: 4.8

I am not sure what is going on here, but there are several unexpected delays between frames that are not normal. I see two different kinds.

  1. Some type of delay between pre-frame actions and frame capture start. I can’t tell what it is and have added logging to get more information.
  2. Something odd is going on with your mount. I suspect it is parked (which is fine), but when we ask it for side of pier information it does correctly respond saying that it doesn’t have a side of pier at the moment… BUT it takes about 10 seconds to get that information. For now, I have added a filtering condition to bypass the side of pier check if the mount is not tracking. That should help with some of the delay, but there are others.

Other considerations:

  • What kind of machine are you running on (specifications… like is it a NUC, how much RAM, etc)?
  • Are you using a remote desktop application?
  • Are you using a virtual machine?
  • Are you using a powered USB hub?
  • Is it very cold outside?

These changes will be in

Hi Ken

The computer is a HP 840 G2 i5 with 16gb of ram and an 1Tb SSD

the remote desktop is the one built in to Windows but it was not engaged while taking tha flats as that would have been quick.

No virtual machine in use.

Yes powered usb hub: Plexgear Desktop 710 USB 3.0-hub

The temperature was about -1C

Your analysis makes some sense to me.

When SGP paused before the flats event i got out to the mount and parked it and turned off the power to the mount.

As i need to move it to one side to be able to add the T-shirt and light source.

That way the mount was still connected in SGP but not turned on.

Let me know if i got this right:

  1. If i had parked the mount, put it to one side and not turned of the power it would have been fine?

  2. If i had slewd the mount to one side with power still on it would have been fine?

Thanks in advance for your quick response and support!



I don’t know. This is wholly dependent on how your mount’s driver handles the mount losing power. Maybe your driver has a ten second time-out before throwing an error.

Thanks for the quick reply, I’ll keep it powered on next time and see if there is a difference.



Issue solved! Keep mount powered while taking the flats and there where no delay and 25 flats where captured in less than 3 min.