"Center here" seems disfunctional in v.

I posted in an earlier thread that I was having difficulty with the “Center here” function. Since that time, I have tried some other things and have to conclude that something seems “broken” in SGP.
Details follow:
This is with v.

1/ Slew to Vega
2/ Blind Synch with the Scope Centering tool. Solve successful in about 10 secs. Scope synch’d.
3/ Select a point on the frame just solved with the mouse cursor, right click and choose “Center here.”
4/ Elbrus quickly fails with an exception error.
5/ Remove Elbrus from the Plate Solving menu in case this is an Elbrus issue.
6/ Again, select a point on the image successfully solved just previously with Blind Sync in the Scope Centering tool and select “Center here.”
7/ Wait . . . a long time (10 mins?) and “fail to solve image” finally appears.

I am able to use a reference image (a sub from previous session), solve it and and use the “Slew Now” and then the “Center Now” functions in the Target Settings page perfectly well.

But the “Center here” function seems not to function at all. Not with Elbrus and not with the local version of the blind solver either.

This function DID work for me. But it was several weeks ago and with an earlier version of SGP.

It’s a really nice function. I’d sure like to get it working again.

Thanks for the description, please see this post:

Can ANYONE verify that they are successfully using “Center here” with v.

From the help file entry for this function: “Description: Center Here is somewhat of a very advanced “Nudge”. It allows you to click anywhere on a captured image and center the scope at the location the mouse was clicked.”

The sequence of events is as detailed in my original post.
SGP v.
OS: Win 7 Home Premium SP 1

Complete log is very long! Snippet where the Center here fails with astrometry.net:

[6/16/2014 10:03:05 PM] [DEBUG] [Telescope Thread] Center here message received…
[6/16/2014 10:03:05 PM] [DEBUG] [Telescope Thread] Center telescope message received…
[6/16/2014 10:03:05 PM] [DEBUG] [Telescope Thread] Solving with Plate Solver Astrometry.NET
[6/16/2014 10:03:05 PM] [DEBUG] [Telescope Thread] Performing Center Here Step 1…
[6/16/2014 10:03:06 PM] [DEBUG] [Telescope Thread] Astrometry.NET convertedAstrometry.fits path: C:\Users\Terry\AppData\Local\SequenceGenerator\Temp\convertedAstometry.fits
[6/16/2014 10:03:06 PM] [DEBUG] [Telescope Thread] Astrometry.NET - File is too large, resizing
[6/16/2014 10:03:06 PM] [DEBUG] [Telescope Thread] Astrometry.NET - Saving file
[6/16/2014 10:03:06 PM] [DEBUG] [Telescope Thread] Astrometry.NET using endpoint:
[6/16/2014 10:03:06 PM] [DEBUG] [Telescope Thread] Astrometry.NET - Calling Async Solve
[6/16/2014 10:03:06 PM] [DEBUG] [Unknown] Astrometry.NET uploading file: C:\Users\Terry\AppData\Local\SequenceGenerator\Temp\convertedAstometry.fits
[6/16/2014 10:11:07 PM] [DEBUG] [Unknown] Astrometry.NET - Upload complete
[6/16/2014 10:11:07 PM] [DEBUG] [Unknown] Astrometry.NET - Waiting for solve to complete
[6/16/2014 10:11:08 PM] [DEBUG] [Unknown] Astrometry.NET solve done in 481 seconds.
[6/16/2014 10:11:08 PM] [DEBUG] [Telescope Thread] Astrometry.NET - Solve Completed
[6/16/2014 10:11:08 PM] [DEBUG] [Telescope Thread] Astrometry.NET - Failed to solve image

I tried with Elbrus too . . . it failed also.

I reiterate that I can plate solve fine. Only the “Center here” function fails. “Center Now” from the “Target Settings” page works fine too.

Doesn’t matter what the image is. A plate solve initiated by a right click on an image and selecting “Center here” from the resulting pop-up menu invariably fails. Even on the very same frame just successfully solved to sync. It fails on the very first step after the “Center Scope on Reference” page opens.

Hope this pins it down.

Yes. The reference image was captured with a previous version. I use PinPoint

Hi there,

Tonight I wasn’t able to use the center here function neither. Plate solving worked like a charm, but when I wanted to center the scope on the just solved frame, it completely slewed of. I was imaging at an elevation of about 30° and after the centering action I had to stop the slew to avoid the scope to hit the dome base ring. The clue is that yesterday everything worked as expected; for the first time using PinPoint.
Clueless; any thoughts?


Ah yes, BTW, I used right click on a solved frame tonight, as I did yesterday. But why should this be an issue?

Just another data point but I have yet to have center fail with a properly solved reference image being used, with any version of SGP. I am using Pinpoint, Paramount ME, TheSky controlled telescope via ASCOM generic hub.

Currently using Mondays updated SGP but have also used the version referenced.

Center here shows as the fail even if your autoguider doesn’t start correctly. That’s my current issue; I can’t get PHD2 to start after the first time… and it fails out.

Hello together, hello developer of SGPro,

the main reason for considering SGPro as my imaging tool is the promised plate solving capability, as it is a really pain and a time consuming process for met to get a faint nebula manually on the correct position.

I am currently testing version as trial version togehter with a trial version of PinPoint, running on a Win 7 32Bit system. The mount is an ASCOM controlled HEQ5.

I spent a valuable clear night for testing SGPro and hope to get some input, so I will do some progress in my testing the next night. (Note: on my location, good night are not so often and also have to “match” with my free time).

I am writing this post not from home as I am working outside and I currently can not provide screenshots or example files. But I hope my explanations are sufficient to give me some hints to solve the problem described below.

I have the same issues as Lex. The “Sync and Solve” works perfectly, but if I click on the just taken image and select “Center here” the mount drives somewhere else. The strange thing is, that sometimes it worked perfectly. On the next 3 or 4 test targets, it moves again to the incorrect positions (10, 20, 30, … degrees off). Then on another target again, it randomly works as expected.
As it sometimes works, I think I can exclude wrong settings (location of mount, data time etc.) as possible reasons. Or?

After that frustrating night, I checked some images I took with SGPro and tried a “dry” plate solve. There I found out, that for some images “Plate Solving” was possible, but not for others. The reason for the plate solve fails, were the incorrect RA and Dec hints. The message box showed something like:

Dec hint: 380422568… (instead something like 38° 04’ …)

I checked the Fits header: In some images, for all numbers the point were used as decimal operator. In other images the fits header shows some values with point and other with comma as decimal operator. (All checked images captured with SGPro)

Note: I was running my testing session completely with German localization settings.

I would not have been astonisheshed, if the fits header had displayed only comma seperated values. Or if only point separated values are displayed (and SGPro could not plate solve running German settings). But that the numeric notation in the fits header is changed from image to image and some images has mixed notation is very strange. (Note: For sure, I did NOT change the localization settings of my Win 7 system during the imaging session).

Might this strange behavior of the fits header, respectively of the corresponding SGPro functionality, also the reason for the randomly wrong moving of the “Center here” command?

I would be very thankfull, if somebody could give some hints!

For sure I will give a try running the system with English (US) localization settings. But I would be glad for a confirmation or if not for an advice, if other settings might be the reason, so that I might spare me some frustrations.

Best regards

Are you using Pinpoint as your primary plate solver for this? Did you have Astrometry.NET selected when you attempted to center?

Please provide some examples via drop box or similar so we can inspect?

It could be… if we don’t know where the image center is (images opened from disk especially), it could produce very odd results. This is almost certainly a localization issue.

Also, please send the logs from this run via drop box as well and we will take a look (Help menu).

Hello Ken,

thank you for quick answer.

I have uploaded two images taken with SGPro and all the log files of the night to “WeTransfer”

The download link is: (I think you already should have received one)

(I think the link is valid for one week)

The image files are CAL_L_1200sec…frame1 and M33_600sec…frame1. While the CAL_L FITS shows some values with comma as decimal operator (RA, Scale, Dec, Angle) the M33 Fits header shows all values with point as decimal operator.

The corresponding log file for the CAL_L image is “sg_logfile_201411020004525”. (I also sent the other log files of the night). Before taking the image the “Center here” worked perfectly. I set up a sequence with 2 images à 20min. As it was late for me, I decided to stop and just take an image of californica nebula “right” of the just taken image to get a starting point for my planned mosaic. So I clicked on a point between center and right border and selected “Center here”. And the scope went off (again for several degrees, instead of some arc minutes).

As far as I have studied the log file, this behavior can be read from the log file.

The initial and successfull “Center here” commands for the CAL_L starts around “02.11.2014 02:07:21”. The failing “Center here” with the just captured image starts around “02.11.2014 02:37:57”.

Before capturing M33 the “Center here” also worked.

I never get the “Center here” working with images taken with the “Sequence Generator” module. It worked for about 2 or 3 out of more than 10 to 15 attempts with images taken with “Frame and Focus”. Note: I am only refering to wrong movements (moving off) of the scope and not to cases where the plate solving itself failed.

I worked myself several years as software developer and I know what it means, if a customer says “I swear, I did nothing”. :slight_smile: So I will try not to behave in the same manner.

But I would be thanksfull for some hints, what I might have done wrong.

Below some additional notes what “I did”:

First the Plate Solving didn’t work at all. After I checked several time my settings I saw that I entered the wrong values for the scale (I entered the pixel size of my camera instead).

After playing around with exposure and binning (I was capturing with a 3,5nm H-Alpha) I got the Plate Solving working.

After the first unsuccessful “Center here” I checked the Site latitude and longitude. And bingo: I transposed some numbers. After correction to the same settings in EQMod, the Center Here worked … For one time. Then several unsuccessful attempts. Until it worked again and then again failing. Note: if I mean “one time” I mean one object. If it starts working for one object I was able to do several corrections with “Center here”.

I got never working “Center here” the telescope pointing to east, only had moderate success with objects on the west.

Carte Du Ciel was running all the time. (as I had no reference images and wanted to move the scope near the regions of interest).

I am very very sure, I did not change the localization settings during the session. I did not think about that until the next day.

Once again, thank you very much for your support.

Best regards



If plate solving is working… have you tried the Framing and Mosaic tool? I use it for composing my images these days. It is very simple… and doesn’t rely on the ‘center to’ feature that has some issues (and is a priority for fixing).

Just some ideas to get you imaging :smile:

Hi mads,

thank you for the tip. I didn’ t have a look at the Framing and Mosaic tool until now. I just watched the demonstration Video and did some “dry” runs. Seems to be very usefull. But I think to get a target really fitting it also has to use the functionality behind “Center here”. So I have to wait, if the issue can be solved or I get a hint what I might have done wrong.

Best regards

I don’t use center here. That’s the only reason I mentioned it :). Good luck!

Hi Reinhard,

I don’t necessarily agree with this… the auto centering functionality can be extremely accurate if your mount allows for it. If your mount does not allow for this (due to mechanical error), then center here won’t help much anyhow. Of the years I have been using and developing SGPro, I have never once had to correct target framing with a manual center here click.

That said, there does appear to be something wrong here… most likely an internationalization issue that we did not consider. We will look at this in the near future.

1 Like