Center scope and Rotate Camera window missing

Hi,
The window of center scope and rotate camera during centering scope is missing bottom part of the status window. All 3.x.x have the same problem. There should are two buttons at that area. But it can not appear properly, no matter what screen resolution or font size I adjusted.

My OS is Windows 10 Traditional Chinese, with 1920 * 1080 screen and resolution.

It looks like something may be overriding the default system font. We’ll have to see if it’s possible to disallow this.

Thank you,
Jared

Actually it looks like we’re already setting this but it’s being overridden at the OS level. you may want to look in your registry at

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes

And see if something is overriding the “San Serif” font. Or I guess it could be that a different font is installed for different language packs.

Thank you,
Jared

Here is my registry at FontSubstitudes


Please check if this may help.

Do you need other information?

No, we’ll just have to attempt to reproduce this. For the time being I think you’d have to figure out what is causing the font to be overridden and default back to the standard Windows 10 fonts. I’m not entirely sure what this entails. They’ve made it somewhat difficult to switch fonts. But I’m guessing it has to do with the language pack.

Jared

I tried modifying register about font. It’s nothing help. I tried setup brand new English version Windows 10 and installed language pack. This problem did not occur in English Windows 10 and language pack installed. The problem only occur on Windows 10 Transnational Chinese version. I also removed FontSubstitutes part of register, it nothing help as well.

After google, I am not sure the following link may help

Moving this issue to support

Please set .net winform AutoScaleMode property from “None” to “Font”, then resolve this problem.

Yes, I hope they resolve this issue.

They did not resolve the problem on V3.2.0.613 until now. I already gave the clue and solution about the problem. I am very very disappoint about SGP team.

Change the MS Shell UI font to Tahoma,

and GRE_Init to following:
“DisableRemoteFontBootCache”=dword:00000000
“ServicingStackModifiedFonts”=dword:00000002
“LastBootTimeFontCacheState”=dword:00000001
“GUIFont.Height”=dword:00000008
“GUIFont.CharSet”=dword:00000086
“GUIFont.Facename”=“Tahoma”

will do the trick

Thanks. It’s work!