Connection Issues on ZWO Cameras

I just bought the ASI 294mm which has two onboard USB ports on the back. I’ve connected the ZWO 290 mini guide camera to one of these ports. The problem I’m having is that I don’t think SGP can differentiate between the two cameras upon connection.

  1. If I connect just the guide camera and not the main camera and I go to connect ASI 1 in SGP it connects to that guiding camera and as such the cooling does not turn on because the camera is not equipped with it.

  2. If I plug both the main camera and the guide camera in it again connects and will not turn the cooler on. Equally when I try to connect to the guide camera in PHD i’m getting errors.

The only work around that I’m finding is to disconnect the guide camera from the back of the 294 and then connect to the 294 first in SGP and then connect the guide camera to the USB port and go connect to it in PHD.

I don’t know what to make of it. I should not have to disconnect USB cables in order to get this working.

SGP comes with ASI 1 and ASI 2. Should I assign the 294 to ASI 1 and the guide camera to ASI 2?

I even tried to isolate the two cameras from each other and not connect the guide camera to the back of the 294 but rather connect it to the HUB where I have my focuser and other things connected, but it still struggles with this.

Any thoughts?

Thanks Sean

Have you installed the latest ASI drivers from here Software and Drivers – ZWO ASI ??

Yes I sure have

With just the 294 connected to the computer and powered on (do not connect the 290 yet), when you open the ASI ASCOM settings in SGP, what does it show?

I’m about to hook it up right now. I’ll get right back with you.

Thanks Sean

Right now it says Ascom ZWO 294

So I went ahead and plugged in the guide camera and connected to it in PHD

Once I did I went back to SGP and clicked on the button again next to the camera and it said this object has been removed, yet it still showed it as being connected.

So I went and disconnected the guide scope through PHD and went back again to SGP and it came up normal with ZWO ASI294 Pro

Then went back again and reconnectd to othe guide camera and now both are connected and its showing the 294 in sgp.

Just to wierd.

In PHD, what driver are you using? It is suggested to use the native ZWO driver in PHD, rather than the ASCOM driver. Choose “ZWO Camera” at the bottom of the camera list, rather than “ASI Camera x”.

I’m not sure what the issue is, but this should at least allow you to use both cameras at the same time without any conflicts.

Okay I sure will. I’ll let you know. Right now its connected and running. I even managed the dark library.

Hey Joel, Just to follow up in case you were wondering, I managed to get all the stuff connected and working. I even managed to take some test shots. However, I have to go through this really squirrelly way to set up SGP. I have to disconnect the guide camera (ASI 290) from the back of the 294 before I power up the camera and start its cooling. After I do that I just plug the 290 back into the 294 and open PHD and connect to it.

If I don’t do it this way and leave it all connected then SGP will connect to the 290 and you know its happening because after it powers up the cooler will not come on and everything is greyed out.
It is what it is so I will just do this untl the newer version comes out and hopefully that will rectify the situation.

To be quite honest, I miss my QSI 690 where the world was so much easier before all these CMOS cameras inundated our market. Give me a solid CCD with my Astrodon’s and Losmandy Mount and I’m a happy guy!

Thanks for your help. I’m sure I will have more to deal with later.

Here’s to keeping my fingers crossed that ATIK can fix my 690…



I used to have similar problems. I believe the problem is in the way ZWO implements their drivers, but is also probably related to a complex interaction between the drivers, PHD, and SGP. I found the order in which I did things with the 2 apps made a difference.

In the end, it worked for me if I let SGP handle everything. Start by using each app individually to be sure you have the right camera selected in each. Then shut them down.

Now, if you have SGP correctly configured to use PHD and select the right PHD equipment profile, all you have to do is start SGP, connect your gear and run your sequence. SGP should have the correct camera connected, and when it needs PHD it will launch that app and select the right profile with the right camera for guiding. But the key is starting up SGP by itself, without PHD running first.

At least that worked for me. Good luck!


This has happened to me before. For some reason when I would plug in my guide camera, my main camera would move to ASICamera2 and my guide camera would become ASICamera1. Before I would launch any software I doubled check using the ASCOM Diagnostics and sure enough my guide camera was ASICamera1 and main camera was 2. By selecting 2 in SGP and 1 in PHD it worked fine until the driver was updated then the flip flopped again.

Thank you Dan I appreciate the input. If I’m reading you right you’re saying that all I have to do is open phd and leave it alone? I know that when I start a sequence it goes and connects to PHD but I did not know that it would actually query the profiles and choose the correct one. I’ll have to test that and check it out. The only problem I would see is that I usually tell PHD to use the last calibration. I think you can program PHD to automatically use the previous calibration without having to actually do it yourself.

While we’re on the subject of PHD. Have you used the multi star portion of PHD? If so what do you think of it?

Thanks Sean

That pretty much sounds exactly what is happening to me. I got it to work the other night but I had to keep the guide camera unplugged until I connected to the 294. I did notice that it was set to connect to ASI 2 though. I did not do this. I went and changed it back to ASI 1 before I made the connection. It’s my understanding that those are just drivers and it should not matter but I could be wrong. Should I assign the 294 to ASI 1 and the 290 Guide Camera to ASI 2 to avoid a conflict?

This whole CMOS sensor camera thing has got me confused!! I’m so spoiled with my QSI 690. Usually it takes me 15 minutes to get polar aligned, plated solved and imaging. Now it seems I have to jump through a bunch of hoops.

Lastly, for those shooting ASI gear do you notice a much more diminished sub image compared to your CCD cameras? I was shooting the Pelican Nebula with the 294 for 20 minutes and the HA sub is way less detailed as I was getting on the same target with the QSI 690. It’s literally night and day between the two images.

I don’t believe you can reliably assign which camera goes to which in ASCOM (I have tried). I also tried renaming them but anytime there was a driver update it would name them back and mess up all my profiles. Just make sure they are both plugged in and confirm which camera is on which “driver number 1 or 2”.

As for your comparison of the ASI294 and the QSI690 I don’t think they are comparable. The 294 is a 14bit camera with a IMX492 Sony chip and the 690 is a 16bit with the Sony ICX814. The Sony ICX814 is a much better sensor compared to the IMX492. A better ZWO comparison might be the 2600 or 6200. I have never noticed a difference in CCD vs CMOS when it comes to polar alignment and plate solving. Just make sure you have your gain set correctly for the 294 based on your setup and conditions. I also believe the 294 has a 4/3 mode and High Resolution mode. Based on your scope and seeing you may want to set it accordingly.

all I have to do is open phd and leave it alone?

Not exactly. Quit PHD and leave it closed. Then when you run the SGP sequnence, SGP will launch PHD and use the selected profile. When I do it that way, it always works.

You have to have SGP set up properly ahead of time though. To do so, you need to go into SGP’s control panel, Auto Guiding tab, and select PHD for the Guiding interface. Then click the “Settings” button on that same tab to select the PHD profile.

I use the ASCOM drivers in both SGP and PHD, and have SGP set to ASI-1, and PHD set to ASI-2. It always comes up with the right cameras.


Thanks Dan, I appreciate everyone’s help. I’ll let all of you know how it turns out!


Agreed - I have also tried, and failed, to lock in the camera assignments.

I find especially that after updating the ASI native or ASCOM drivers, the assignment changes, and I have to go back into both PHD2 and SGP to make sure everything is assigned properly.

1 Like