Crazy Problems with ASI1600mm Pro

I’ve updated ASCOM and the ZWO drivers to the latest (as of 5/20/2020), but am having a devil of a time with things like:

  • Error message “Please input Exposure Duration between 0 and 0 s, and restart exposure!”
  • Camera hang on download under Frame and Focus
  • Error message when I click on the tool icon for Camera “This ASI camera is removed”
  • Camera won’t cool

Any insight would be much appreciated. I’ve been using the camera flawlessly with SGP for over a year, and these are only recent problems.

Sounds like you have a cable going bad. Also, if you still get the hang on frame and focus you can slow down the USB traffic speed under camera driver options (after you fix the connection issue).


Thanks, Charles. I’ll give it a try.

I’m wondering if I also have USB problems with my laptop. I’m using EQMOD and a “external telescope disconnect” message happens every so often, but am using a direct from mount cable for that (EQ6R Pro).

I’ve had that exact same problem with my EQ6-R using eqmod and it was a cable as well. All my stuff went through a hub on the scope and I’ve have two cable go bad at once! Usually in the winter when they get brittle. Hopefully that’s all it is.


I’m hoping that’s all it is. I recently upgraded to the Pegasus Ultimate Powerbox v2 (after having no issues with the Pocket Powerbox), so hope the powered USB ports aren’t having any problem.

I’ve also added another telescope/camera combo on the same mount while running two instances of SGP on the same laptop. So, I have the ASI1290 mini guide camera, ASI1600mm cooled pro, and QHY 183M. They all worked fine until a few days ago, but maybe I bit off more than I can chew!