D810A won't connect as D810

The camera has only been out a week or so, so it is a bit unfair of me to be howling about it not working with SGPro, but since there is support for the D810 I figured I’d try it anyway, but when I selected it as a D810 SGPro won’t connect. I have a D800 that works fine with SGPro so I know about having the cards out etc…
Hopefully it’s a trivial fix, I suspect not many have tried hooking one up yet so I thought I’d let you know.
Andrew Lockwood.

What version of SGPro are you using? What happens when you select “Auto Connect”?

Thanks Ken - I’m using
Setting the camera as autoconnect produces the failed to connect - remove SD card pop-up, This works instantaneously on the D800 though.
thanks for your prompt response!

Ditto, it does not work, on my installation the D810 will not connect and suggests removing SD card.
On auto connect it will claim de MSVSP110.DLL is missing and crashes SGP …


I tried DigiCamControl, and it connects and I can take pictures, but the Timelaps feature and LV are not working …


It doesn’t work for me either.

It says that Nikon will publish a new SDK for D810A.

Will D810A be supported by SGP when the SDK is available?

Thank you.

It is very likely. When we get our hands on a new SDK with support, we will put a beta out for testing.

The SDK has been released for a while.

Is D810A going to be supported soon?

Thank you.

The D810A is still not listed.

Hi Ken,

It is the first one on the list :smile:
It has tricked me for a while as well.

Ah thanks. We will but a build together in the near future. Not exactly sure when.


Looks like it was added 3 days ago. I’ll grab it this evening but it will likely take some time to integrate with it.


Thank you guys!

Can’t wait!