Data entry boxes not incrementing

Using SGP ver, last night I noticed that any data entry box that has both up and down arrows will no longer increment data if you hold one of the buttons. It will increment up and down with single clicks of the button, but if you hold the button down it no longer increments up or down by it self. It worked this way with ver 3, but I don’t know if it ever worked in ver 4. I’ve only been on ver 4 a short time. This was a very handy feature…without it I have to turn a light on in the Dome to be able to see the keyboard and manually enter the value, while before i could just hold the button till I got close to the value I wanted and fine tune it with single clicks.


Ya… I kind of hate the new numeric entry controls we made in order to support themes (the ones found in SGPro 3 don’t support themes so we had to make a control that did). Not only are some of the input controls wonky, the text looks funny, it’s too big and there is no padding between the text and edge of the control. It needs to just be redone entirely I think.

No worries! Just me whining as a lazy astronomer! Literally take 5 seconds to enter the number rather than holding a button down. Rather have the nice themes than the incrementing button any day! My wife keeps pointing out with all the automation SGP now provides me I don’t have to do any work it’s all done for me, and that soon I won’t even have to go out to the Observatory any more. Hmmm that’s an idea!
By the way, I’ve run three more full sequences without the target hanging problem!